Project

General

Profile

Bug #137

Reports of Inability to Attach/Download Attachments to Forum Posts

Added by Matt Gold over 12 years ago. Updated over 12 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Upgrades
Target version:
-
Start date:
2009-12-09
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

Reposting from a previous ticket, which didn't have the whole team on as watchers.

George is telling me that he can't access an attachment that was recently posted in the videoconferencing group. He's also unable to see the tools for attaching a file of his own to a post. He's using Mac FF/Safari. I can't test because I don't have that setup here.

Please see attached Mac FF screenshot. He sees the same thing in safari

This sounds a lot like what we saw before here: http://issues.commons.gc.cuny.edu/issues/show/126

nomeansofattachmenting.jpg (236 KB) nomeansofattachmenting.jpg Matt Gold, 2009-12-09 04:27 PM
icanattachfiles.png (44.3 KB) icanattachfiles.png Lucas Thurston, 2009-12-09 04:35 PM
updated.jpg (250 KB) updated.jpg Matt Gold, 2009-12-09 06:24 PM
safarifailure.jpg (274 KB) safarifailure.jpg Matt Gold, 2009-12-09 07:51 PM
firefoxfailure.jpg (240 KB) firefoxfailure.jpg Matt Gold, 2009-12-09 07:51 PM

History

#1 Updated by Matt Gold over 12 years ago

forgot to mention that I tested the group with WinXP/Chrome and could see/download the attachment without a problem.

#3 Updated by Lucas Thurston over 12 years ago

Could this be a permissions issue of some sort or a setting on the forum or the group? I do see the fields if FF/Mac, so I think this is a configuration issue.

#4 Updated by Boone Gorges over 12 years ago

  • Status changed from Assigned to Reporter Feedback

I can't reproduce the problem. Works fine for me on Mac FF 3.5, Safari 4.0.4, and Chrome. I can see and use both existing file attachments and the Attach Files dialog under new posts. Since it's rendered on the server there shouldn't be a difference between browsers.

I just read Lucas's post and I had the same thought. There are a few places in this plugin where it checks for user permissions. I thought I had it working right, but for now I have commented out the permission check, so that anyone who can read the forum can download items, and anyone who can see the input box can see the Attach File box. I guess that's how it should work anyway - my commenting has essentially moved permission out of the plugin and into Buddypress, where it belongs anyway.

BTW, the forum post in the screenshot doesn't have attachments in any browser, just a link. The other thread in the group forums does have an attachment, though.

Also, I just tested a non-admin user account and I'm able to see everything.

Please ask George to try again.

#5 Updated by Matt Gold over 12 years ago

Thanks for your quick attention to this, everyone. I've asked George to give it another shot, but I have to leave the office now and won't be back home for an hour.

#6 Updated by Boone Gorges over 12 years ago

OK. I won't be able to look more tonight - I have visitors for the evening. Hopefully it'll be fixed, but I'll look at it tomorrow if there's still an issue and no one else gets to it first.

#7 Updated by Matt Gold over 12 years ago

Hi Guys,

Apparently, the problem continues. Here's George's report:

I'm in a meeting so this is hard, but I even ran out and tried someone's
Dell/IE. I see the button to "post reply" but not means of doing an
attachment, even there.

But this (the attached) is from Firefox on my Mac -- closed, cleaned,
reopened, reloaded.

#8 Updated by Matt Gold over 12 years ago

I gave George the login credentials of our teststudent account and asked him to check out the group so that we can see whether the problems are localized to the gotte account. Will report back on what I hear.

#9 Updated by Matt Gold over 12 years ago

and just heard that George won't get to this until 10, so let's deal with this tomorrow.

#10 Updated by Matt Gold over 12 years ago

George had the same results on FF/Safari when logged in as teststudent. Screenshots attached.

#11 Updated by Boone Gorges over 12 years ago

I was able to reproduce the problem with the teststudent account. Turns out it was indeed a permissions problem (one beyond the ones that I'd mentioned in a previous update to this ticket). I've removed the permissions check (which is redundant anyway in Buddypress) and the problem went away for the teststudent account (on all browsers I checked - but this problem really ought to be browser independent).

Again, I'll need feedback from George before being sure.

#12 Updated by Matt Gold over 12 years ago

Thanks so much, Boone. I'm waiting to hear back from George.

#13 Updated by Matt Gold over 12 years ago

  • Status changed from Reporter Feedback to Resolved

George can now see the upload buttons. Fantastic work on this, guys. Many thanks for your quick attention to this.

Also available in: Atom PDF