Project

General

Profile

Bug #1375

Redirect loop?

Added by local admin over 9 years ago. Updated about 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-11-22
Due date:
% Done:

0%

Estimated time:

Description

Boone, just noticed that googlebot is bumping against some redirect errors when crawling today. Not sure if they are looking at the right URLs or if this is even in fact an issue, but thought you'd like to know.

Attaching the .csv report in case it's meaningful...

History

#1 Updated by Boone Gorges over 9 years ago

  • Status changed from New to Hold
  • Target version set to 1.3

Thanks for the info, André.

It looks, at a glance, like the problem lies in a problem with our current version of BuddyPress. BP does some internal redirection in order to canonicalize activity permalinks, but in earlier versions of BP, those redirects would sometimes go awry when the activity item had been deleted, or could not be found for some other reason. This has been fixed in the most recent version of BP, which returns a proper 404 response code in this case. Let's check this again after the 1.3 update has been live for a while, since that'll bring us the latest version of BP.

#2 Updated by local admin over 9 years ago

Right on, man.

#3 Updated by Boone Gorges over 9 years ago

  • Target version changed from 1.3 to Not tracked

#4 Updated by Boone Gorges about 7 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from Hold to Resolved

Having seen further reports of issues, so I'm marking resolved.

Also available in: Atom PDF