Project

General

Profile

Support #13878

When creating Group + Site and choosing 'Clone existing', cannot advance to step 2

Added by Marilyn Weber 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Group cloning
Target version:
Start date:
2021-01-25
Due date:
% Done:

0%

Estimated time:

Description

Bret Maney, who teaches in Matt's DH program, writes:

I'm trying to use the clone a group+site option to clone a teaching site and group for a new semester. When I go through the creation portal and choose "create a site+group," then "clone an existing group," selecting "Yes, clone the Group's associated Site," add in the details for the group, and click "clone group," it clones the group but then takes me to the "create a new group" page rather than allowing me to enter details about the site to be cloned. Is this a bug perhaps or am I just missing something? It seemed to work differently here: https://help.commons.gc.cuny.edu/create-or-clone-a-group-plus-site/
Thanks!

He followed up the next day with more info:

I decided to clone my site (new site: https://dhpraxis21.commons.gc.cuny.edu/) and then create a group (https://commons.gc.cuny.edu/groups/dhpraxis21/) and then connect them by going to the “Group Site” option under “Manage” in the group.

You’ll notice I selected “Enable group site” and the “Connect an existing site” option. However, when I try to enter the url for the site I want to connect, I get a “Sorry that site URL is already taken” error. This error seems counterintuitive because I’m trying to connect my group to an existing site, one for which the url will always already be taken.

image001.png (36 KB) image001.png Marilyn Weber, 2021-01-25 09:48 AM

Related issues

Related to CUNY Academic Commons - Bug #13879: Group > Manage > Group Site - Radio buttons not triggering UI changeResolved2021-01-25

History

#1 Updated by Marilyn Weber 11 months ago

Also - " As a workaround, I ended up cloning the site and group separately with plans to connect them." But then got the attached error

#2 Updated by Boone Gorges 11 months ago

  • Description updated (diff)

#3 Updated by Boone Gorges 11 months ago

  • Related to Bug #13879: Group > Manage > Group Site - Radio buttons not triggering UI change added

#4 Updated by Boone Gorges 11 months ago

  • Subject changed from cloning problem to When creating Group + Site and choosing 'Clone existing', cannot advance to step 2
  • Category name set to Group cloning
  • Assignee set to Jeremy Felt
  • Priority name changed from Normal to High
  • Target version set to 1.18.4

You’ll notice I selected “Enable group site” and the “Connect an existing site” option. However, when I try to enter the url for the site I want to connect, I get a “Sorry that site URL is already taken” error. This error seems counterintuitive because I’m trying to connect my group to an existing site, one for which the url will always already be taken.

This issue seems unrelated to cloning, so I've broken it out into #13879.

As for the other issue, I've changed the title of this ticket to reflect the problem in more detail. Here's a clearer breakdown of what's happening:

1. Groups > Create a Group > Create a Group + Site
2. Select 'Clone an Existing Group', and select a group from the list
3. Make sure that 'Yes, clone the group's associated site' is selected
4. Fill out the rest of the form and hit Continue
5. The page submits, and the group is created, but you are returned to step 1 of the creation process ('Group Details') instead of being advanced to the next step.

Regular Group creation (not Group+Site) does not appear to be affected.

Jeremy, could you have a look please?

#5 Updated by Marilyn Weber 10 months ago

Ay advice on what Bret should do now? Thanks!

#6 Updated by Boone Gorges 10 months ago

I don't have any solid suggestions until the team has had a chance to look at the underlying problem.

If it's urgent to get the group and site connected now, the user could pass along the URL of the group and the site and I could try to connect them manually. If it's not urgent, it'd be best to wait a few days while we diagnose on our end.

#7 Updated by Jeremy Felt 10 months ago

I have confirmed the issue locally and I'm digging into the cause. Unfortunately (fortunately?), this bug existed in the feature branch as well, so there isn't a conflict with any new code to track down.

I'm hoping to have a better answer/solution shortly.

#8 Updated by Jeremy Felt 10 months ago

A PR to address this issue on the 1.18.x branch: https://github.com/cuny-academic-commons/cac/pull/7

Interesting additional info: The form did work if filled out and submitted a second time. The loop only happens on the first submission.

#9 Updated by Boone Gorges 10 months ago

  • Status changed from New to Resolved

Thanks, Jeremy! Fix looks good. I've deployed it as a hotfix.

Also available in: Atom PDF