Project

General

Profile

Support #14077

Elementor Pro plugin for the slider

Added by Marilyn Weber 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2021-02-28
Due date:
% Done:

0%

Estimated time:

Description

Via Zendesk:

"I am having issues with my slider on my homepage. It works fine when I insert it into the page. When I go back and open the website again the slider stops working. The automation freezes and you can no longer click or scroll the slides.

I am using the Elementor Pro plugin for the slider.

Thank you,
Michelle

------------------
Submitted from: https://corebooks.commons.gc.cuny.edu/home/"

Boone, I see that you originally installed the related plugins on this ticket https://redmine.gc.cuny.edu/issues/13738

History

#1 Updated by Boone Gorges 7 months ago

  • Category name set to WordPress Plugins
  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges

Can I get some more details on how to reproduce? I see that there is a slider at https://corebooks.commons.gc.cuny.edu/home/, if I scroll down about three-quarters of the way down the page. See screenshot. This slider seems to work fine. Maybe I'm looking at the wrong place?

I'll need a specific URL, along with specific steps to reproduce. In addition, it would be helpful to know the browser and OS of the user.

#2 Updated by Marilyn Weber 7 months ago

I'm waiting for her reply but I do see what she means. The animation is stuck on Song of Solomon. I'm using a PC and have the same problems on Chrome, Firefox and Edge

#3 Updated by Marilyn Weber 7 months ago

She replies "Thank you for reaching out. So the slider is the bottom one with the book images. You can't click on the arrows or toggle buttons at the bottom to scroll the book images. The book images also should be on an automated rotation.

The About Us page (https://corebooks.commons.gc.cuny.edu/about-us/) is also experiencing the same issue with the quote bubbles at the bottom of the page. You can't click to view the other quotes and it seems to be stuck on just one."

#4 Updated by Boone Gorges 7 months ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Thanks for the clarification. The Elementor term for this sort of element is "Media Carousel". I confirm that the carousel doesn't seem to be working.

It's not a general JavaScript failure, as it's still possible to interact with the carousel by grabbing and sliding. It's just that the advance mechanism doesn't work.

Ray, could you spend a few minutes to see if anything obvious occurs to you? If not, we'll have to ask the user to post a support request to the Elementor team. https://wordpress.org/support/plugin/elementor/

#5 Updated by Raymond Hoh 6 months ago

I think this is a bug with Elementor:
https://github.com/elementor/elementor/issues/12346

But might be fixed with the latest version of elementor-pro. Latest version is 3.1.1; we're on 3.0.8. Michelle would need to provide us with that. Here's the changelog for the pro version: https://elementor.com/pro/changelog/. But I couldn't find anything relating to the Media Carousel being fixed.

We're also updating the regular version of elementor tomorrow from 3.1.1 to 3.1.3, but I don't see anything relating to the carousel in the changelog either: https://wordpress.org/plugins/elementor/#developers.

I would suggest updating everything to the latest versions first to see if that might fix things. If not, then Michelle can reach out to Elementor since they use the Pro version and should be entitled to premium support.

#6 Updated by Boone Gorges 6 months ago

Thanks, Ray. This all sounds sensible to me.

#7 Updated by Boone Gorges 6 months ago

  • Status changed from Reporter Feedback to Staged for Production Release
  • Target version set to 1.18.7

Today's release will involve an update to elementor-pro 3.2.0 (provided privately by Michelle). I'll tentatively mark this ticket Resolved after the release, but Marilyn, feel free to reopen with more details if we continue to see issues.

#8 Updated by Boone Gorges 6 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF