Project

General

Profile

Support #14148

post notification problem

Added by Marilyn Weber 9 months ago. Updated 3 months ago.

Status:
Abandoned
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
-
Start date:
2021-03-11
Due date:
% Done:

0%

Estimated time:

Description

Syelle Graves reports:

"I recently published this post, but got no email notification: https://francaiscuny.commons.gc.cuny.edu/?p=463&preview=true

I went to profile > settings, and don't see any email address in "Account Email"--it shows my username instead. ("syellegraves").

Any idea why I got no post notification?
I'm hoping to verify that this notification was sent out to all site members.

And, is it expected behavior that Account Email does not show me my account email?

Two screenshots attached. Thank you!"

History

#1 Updated by Boone Gorges 9 months ago

  • Status changed from New to Reporter Feedback
  • Private changed from No to Yes

Looks like there's a few things going on here.

First: The screenshot showing the notification setting "Receive notifications of my own posts" is specific to group forums. It's unrelated to blog posts. It's possible to get email notifications of blog posts, but only if the site is linked to a group; it doesn't appear that this site is so linked.

Second: It's unclear to me how or why the 'Account Email' field would have the user login in it. I did some triangulation between the outgoing mail logs and what's in the database, and it looks like Syelle does have a valid email address associated with her account, but it looks like she might have changed it in the last couple of days: first it was , and on Mar 10 it seems to have been changed several times between and . Maybe this was Syelle testing this setting? So I'm not quite sure. Is it possible that it was originally the gmail address, but then she accidentally removed the "@gmail.com" part and resaved it? It seems like this shouldn't be possible, because BuddyPress validates that the entered value appears to be a valid email address, and throws an error if it's not. Adding Ray as a watcher in case he has any ideas.

#2 Updated by Raymond Hoh 9 months ago

I'm guessing the "syellegraves" text in the "Account Email" field is caused by Syelle using a password manager browser extension that autofills certain forms on a page. I don't think this is a bug with WordPress or BuddyPress.

#3 Updated by Marilyn Weber 9 months ago

I've reported this to Syelle. I wonder why the site and group aren't linked - my guess is that was an oversight.

#4 Updated by Marilyn Weber 8 months ago

Can Syelle be added to this ticket? Scott too. Thanks!

#5 Updated by Marilyn Weber 8 months ago

Also Laurie

#6 Updated by Boone Gorges 8 months ago

Added Scott, Laurie, and Syelle as watchers.

#7 Updated by scott voth 8 months ago

Hi Syelle - If you are not using a group attached to a site, I think the best way to notify site members of posts is by using the JetPack plugin and enable subscribe (under Discussion).

See https://help.commons.gc.cuny.edu/jetpack/
And:
https://help.commons.gc.cuny.edu/subscriptions-to-your-site-with-jetpack/ (this one is a little outdated - needs updating)

#8 Updated by Boone Gorges 8 months ago

  • Private changed from Yes to No

#9 Updated by Boone Gorges 3 months ago

  • Status changed from Reporter Feedback to Abandoned

Closing due to inactivity.

Also available in: Atom PDF