Project

General

Profile

Support #14242

LAILAC site missing content

Added by Marilyn Weber 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
-
Start date:
2021-03-25
Due date:
% Done:

0%

Estimated time:

Description

Rosalia Reyes Simon reports via ZD: "I´m writing to request your help because I can´t see the content on the LAILAC´s CUNY Commons website.

https://lailac.commons.gc.cuny.edu/"

Going to the site, I see exactly what she means. She also send a screenshot of the site from last week where everything looks great (attached)

Looking at the back end, I do see that there's a discrepancy between the menu up top, and the categories she's using when she creates a post. But that doesn't explain why it worked last week. So I've cloned the site at https://l2tester.commons.gc.cuny.edu/ and have tried to re-do the menu to reflect the categories. I created a new post, and tried with her old posts, and I can't get anything to appear either.

The theme does have a warning - "Howdy! Your current theme, Imbalance, has seen an update in the form of a brand new theme, Rebalance. For more information, check out our blog post introducing Rebalance to the world."

So I'm trying the Radiate theme, but I can't recreate the look she had, with many posts side by side.

Can this be fixed with Imbalance as the theme? Or what should I do? Thanks!

image (1).png (255 KB) image (1).png Marilyn Weber, 2021-03-25 08:55 PM

Related issues

Related to CUNY Academic Commons - Bug #13353: jQuery update strategyResolved2020-09-21

History

#1 Updated by Boone Gorges 8 months ago

  • Related to Bug #13353: jQuery update strategy added

#2 Updated by Boone Gorges 8 months ago

This is a jQuery incompatibility. See #13353. I've put a hotfix in place for the imbalance2 theme that appears to fix the homepage.

I'll take a closer look tomorrow to see whether it's possible/necessary to make further changes to imbalance2, and I'll try to make a recommendation about whether to migrate away from the theme.

#3 Updated by Boone Gorges 8 months ago

  • Status changed from New to Reporter Feedback

I confirmed that Automattic (creator of imbalance2) updated the theme to provide jQuery 3.x compatibility. I've applied that change as a hotfix: https://github.com/cuny-academic-commons/cac/commit/d4d57709457ba8ed89cb564a896d058909dbfd99

Marilyn, could you confirm (and confirm with the user) that the site is working properly? I want to be sure there's nothing I've missed.

I don't think it's necessary to switch to a new theme at this time, though it may be advisable to do so at some point if only because imbalance2 is no longer seeing regular updates, so is likely to feel outdated down the road.

#4 Updated by Marilyn Weber 8 months ago

Yes, I'll check with her.

Do you think we will add Rebalance to our theme set? It looks like the grid layout I personally like, so I would give it a go if it were there.

#5 Updated by Boone Gorges 8 months ago

For context, imbalance2 is currently used by 44 sites on the network, and it is network-enabled, meaning it's selectable by new sites. If it were an easy thing to do, it would be nice to swap out imbalance2 for rebalance and switch over all existing users. But this kind of swap-out is almost never one-for-one, meaning it will require a fair amount of research and due diligence. So, given that imbalance2 doesn't seem to be causing any problems other than the one described in this ticket, I'd suggest it's not worth the effort to do this.

In this case, we'd be introducing Rebalance alongside imbalance2. I would only want to do this if Rebalance were really excellent and filled a gap in our theme selection. But it appears that Rebalance is not fully supported. See https://wordpress.org/themes/rebalance/ - it hasn't been updated since March 2018. For these reasons, my vote is not to add it to our theme selection.

If we want something with a grid layout (and don't already have something comparable), we should look for something that's actively maintained.

#6 Updated by Marilyn Weber 8 months ago

I agree then. No update since March 2018 seems like a bad sign.

I personally use Color Mag for its grid layout, but I don't love it. Does anyone have other suggestions? Sorry to hijack this thread!

#7 Updated by Boone Gorges 8 months ago

Scott is the resident expert on what's available on the Commons, so I defer to him :-D

#8 Updated by scott voth 8 months ago

The masonry layout can be done with the Bridge theme. Bridge is complex and may take some time to get familiar with, though.

For an example, see: https://bccarchives.commons.gc.cuny.edu/

#9 Updated by Matt Gold 8 months ago

should we consider disabling the network availability of imbalance2? I don't see it, btw, on the WordPress theme viewer (https://wordpress.org/themes/search), but instead see it in the following places:

https://www.themeshaker.com/theme/imbalance-2-modern-art-magazine-wordpress-theme

https://www.themeshaker.com/theme/imbalance-2-modern-art-magazine-wordpress-theme

Is imbalance2 being maintained actively?

#10 Updated by Boone Gorges 8 months ago

I don't believe imbalance2 was ever listed in the wordpress.org theme repository. We get it from the wpcom-themes SVN repo maintained by Automattic.

The theme is not "actively maintained" in the sense that it doesn't receive any new features. However, it does appear to get bug fixes, such as the jQuery fix described in this ticket.

I lean toward disabling it, if only because it's so old.

#11 Updated by Marilyn Weber 8 months ago

Rosalia is all set with her site.

Scott, I might check our Bridge, but I was hoping for straightforward.

Boone, going to Automattic then the wordpress.org theme repository allowed me to get here - https://wordpress.org/themes/tags/grid-layout. Do we have or can we tr any of those? BlogLife and Occasio looked pretty good to me. I can open a new low-urgency ticket about this. Rosalia makes me thing I'm not the only one who likes a busy blocky layout.

#12 Updated by Boone Gorges 8 months ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Marilyn. Please feel free to open a separate ticket where we can discuss this.

#13 Updated by Matt Gold 8 months ago

Boone Gorges wrote:

I lean toward disabling it, if only because it's so old.

I lean towards disabling for new users, as well.

#14 Updated by Boone Gorges 8 months ago

I've network-disabled imbalance2.

Also available in: Atom PDF