Project

General

Profile

Actions

Bug #14299

closed

Remove Site Health scheduled task

Added by Raymond Hoh over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2021-04-09
Due date:
% Done:

0%

Estimated time:

Description

WordPress introduced a Site Health feature in v5.2:
https://make.wordpress.org/core/2019/04/25/site-health-check-in-5-2/

This feature adds a weekly scheduled task to determine if WordPress is optimized. The problem is this task is registered for every site on the Commons, which can bog down and overwhelm Cavalcade, our scheduled task runner (see #14276).

Also on a multisite install, only a network admin can view the Site Health page, which means this scheduled task is completely unnecessary.


Related issues

Related to CUNY Academic Commons - Bug #14276: Increase number of workers in CavalcadeDeferredRaymond Hoh2021-04-02

Actions
Related to CUNY Academic Commons - Bug #9930: wp_privacy_delete_old_export_files runs a bazillion timesResolvedBoone Gorges2018-06-14

Actions
Actions #1

Updated by Raymond Hoh over 1 year ago

  • Related to Bug #14276: Increase number of workers in Cavalcade added
Actions #2

Updated by Raymond Hoh over 1 year ago

  • Related to Bug #9930: wp_privacy_delete_old_export_files runs a bazillion times added
Actions #3

Updated by Raymond Hoh over 1 year ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF