Project

General

Profile

Bug #14411

logo problems

Added by Marilyn Weber 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Themes
Target version:
Start date:
2021-05-03
Due date:
% Done:

0%

Estimated time:

Description

We have two ZD tickets reporting logo problems:

1) From Brianna Caszatt, yesterday morning:

"I've tried updating and removing my page's logo, and it's still showing an old logo that I only added in as a placeholder.

Every other update I make shows up instantly, but this element doesn't update and I don't know why. Is there a site cache somewhere I can clear? When I check the site on another device, it's now displaying an empty box as I've removed the image from our media library. So I don't see how it could be my own computer's cache causing the problem.

Here is my site link: https://mappingcemeteries.commons.gc.cuny.edu/"

Later in the afternoon:

"Now that you’ve emailed me, my logo seems to have disappeared. I don’t have a replacement logo yet (and might not include one), so I guess this issue is resolved for now. It was just strange to me that the old logo was hanging on for so long (more than 24 hours), when every other change I’ve ever made to the site has been almost instant.

I will let you know if I have any further problems when our group has agreed on a replacement logo."

2) From Marianne Madoré, today

I would like to restore the settings of my theme to "default settings" and a quick search on the internet told me that it was easy to it with the plugin "WP reset" unfortunately, it looks like it s not available in the list of plugins we have accessed to via the Commons, would it be possible to add it?

alternatively, the reason I want to reset the theme, is because i believe this is a bug on my home page. I deleted my logo (on purpose) but the header is still showing the place holder for the logo (an empty square with the words: back home" and the icon of a missing image) see attached screenshot ://

https://cunyandthecia.commons.gc.cuny.edu/

Capture.JPG (12.1 KB) Capture.JPG Marilyn Weber, 2021-05-03 11:45 AM

History

#1 Updated by Boone Gorges 6 months ago

  • Category name set to WordPress Themes
  • Status changed from New to Resolved
  • Target version set to 1.18.10

Both of these sites use the Customizr theme, and I've tracked this down to a cache issue in the theme. I've reported it to the theme author at https://wordpress.org/support/topic/logo-settings-cache-not-properly-invalidated/.

In the meantime, I've got a fix in place that allows us to skip their caching mechanism for logos, which appears to solve the problem. https://github.com/cuny-academic-commons/cac/commit/a8aa9f706501fb14b51c21efbbdcae458c26b690

#2 Updated by Marilyn Weber 6 months ago

Thanks! Confirmed, BTW:

Brianna Caszatt
Today ‪03:31 pm‬

Yes. I confirm the issue has been resolved.

Also available in: Atom PDF