Project

General

Profile

Bug #14444

Possible bug with CTC plugin?

Added by Syelle Graves 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2021-05-11
Due date:
% Done:

0%

Estimated time:

Description

I am encountering a mysterious problem with the Configurable Tag Cloud plugin. I set it up, I see it on the site, and it looks gorgeous; then I refresh the screen, and it disappears. It still shows in dashboard > appearance > widgets, but it does not show on the front end of the site after one refresh.

I have seen/re-created this on two different sites.

I also tried:
-multiple themes (2017, 2016, Academica, Customizr)
-different sidebars and footers
-removing all other widgets
-deactivating and reactivating the plugin
-deactivating the Widget Context plugin
-changing the number of tags it should show

I was able to capture the phenomenon in a few screencasts (sorry for the length):
https://cuny.zoom.us/rec/share/A1MV3B0p98_81BozsygRhfS7T91JqluumpqzFKt8SdpfL-Dxdn4Ae50IxvN5fIMZ.jgprAss0_0qQOPs2
https://cuny.zoom.us/rec/share/dF6p7Hsj2k5kxE157SJFgsD5DxOBpQvQoakw6rnfRSMoOnSLeXWZ_zlYti_ornv8.mwGXKKG6oW4jtnfr

Is it possible to look into this? We would love to use it on our site, because it displays more than the 45-lmit of tags in the normal tag cloud widgets, and the slim profile of the drop-down option is so useful to us.

Here is a link to the main site I’m trying to get it to work on, but again, it seems to happen in multiple Commons sites. https://8nsshl2021.commons.gc.cuny.edu/category/presentations/

Thanks so much!

History

#1 Updated by Boone Gorges 5 months ago

  • Status changed from New to Resolved
  • Target version set to 1.18.11

This is a problem with the cache implementation in the plugin, which is very old and appears to be unmaintained. See https://wordpress.org/support/topic/cant-get-ctc-to-display-with-site-cache/. I have fixed it on the Commons in https://github.com/cuny-academic-commons/cac/commit/e72c52dbb8fbe56d88e27f96535ba7e87c862367, https://github.com/cuny-academic-commons/cac/commit/d7a9ac89dbc92a531311c4f5b48429754621232e It now appears to be working properly.

#2 Updated by Syelle Graves 5 months ago

YES! It just now rematerialized. We're very happy!

#3 Updated by Boone Gorges 5 months ago

Thanks for confirming!

#4 Updated by Syelle Graves 5 months ago

New update: The widget is still staying put, but today, I renamed it (in dashboard > appearance > widgets > CTC > title > save), and the new widget title does not show on the front end. I checked several browsers.
Could this be related to the caching issue you solved?

https://8nsshl2021.commons.gc.cuny.edu/category/presentations/

#5 Updated by Boone Gorges 5 months ago

Yes, it appears to be related. It's not obvious to me why the issue is occurring, other than that the plugin is not written properly to invalidate its cache. We haven't got the resources at the moment to do a full review of the plugin's code to address all issues, so I've added a flag to the plugin that disabled its use of the cache altogether.

#6 Updated by Syelle Graves 5 months ago

Amazing! Thank you. That worked.

Also available in: Atom PDF