Project

General

Profile

Bug #14448

password reset weirdness

Added by Marilyn Weber 3 months ago. Updated 3 months ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Password Reset
Target version:
Start date:
2021-05-11
Due date:
% Done:

0%

Estimated time:

Description

Via ZenDesk: "I am having issues trying to reset my password. When I enter my new password and click on “Reset Password” I get the passwords don't match warning." She then sent me an image showing that there's no place to re-enter your password once you change it. (images attached)

I thought this was user error, so I tried to change the password on my account associated with . I received an entirely blank email (also attached).

Then I tried with . This worked fine: I received a non-blank email (attached), clicked on the link and saved my password without problem. Logged in with the new password.

Any thoughts?

passwords don_t match.png (10.7 KB) passwords don_t match.png Marilyn Weber, 2021-05-11 06:43 PM
no place to re-enter.png (82 KB) no place to re-enter.png Marilyn Weber, 2021-05-11 06:43 PM
mweb05 attempt.jpg (47.1 KB) mweb05 attempt.jpg Marilyn Weber, 2021-05-11 06:47 PM
entirely blank email.jpg (28.1 KB) entirely blank email.jpg Marilyn Weber, 2021-05-11 06:47 PM
nevermind.JPG (47.1 KB) nevermind.JPG Marilyn Weber, 2021-05-11 06:59 PM

History

#1 Updated by Boone Gorges 3 months ago

  • Assignee set to Raymond Hoh

Ray, could you have a look? I know you've done some work implementing password-strength tools in various parts of the interface, though I'm unsure whether this issue (these issues?) are related

#2 Updated by Marilyn Weber 3 months ago

The plot thins! I think you can ignore my not-getting-the email problem. That is only true if I am not VPN'd in. I receive the full email when I am using VPN (see "nevermind" attachment). IThis is annoying but not the Commons' problem.

Now I'm a little back to thinking user error. I've asked the user to try with a different browser.

#3 Updated by Raymond Hoh 3 months ago

I can duplicate her "no place to re-enter.png" screenshot when inline javascript is disabled on the page. However, I am still able to submit the reset password form successfully.

If I disable javascript entirely, I can see both "New password" and "Confirm new password" fields.

So some form of blocking is taking place in her browser. Can you ask which browser addons she is using?

#4 Updated by Marilyn Weber 3 months ago

She tried in another browser and now has succeeded. She was using Firefox. This can be closed.

#5 Updated by Raymond Hoh 3 months ago

  • Category name set to Password Reset
  • Status changed from New to Rejected
  • Target version set to Not tracked

Thanks for following up, Marilyn.

I was using Firefox for my tests and the reset password form was able to submit properly. (My Firefox setup is also more hardened than most.) If we get more reports of reset password problems, then we can spend a bit more time on this. For now, I'm going to close this.

Also available in: Atom PDF