Project

General

Profile

Bug #14451

Search filtering not working correctly

Added by Laurie Hurson 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Blogs (BuddyPress)
Target version:
Start date:
2021-05-12
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

When trying to look up all sites with purpose classified as "conference", the results do not appear to be correct.

Screenshot and video of conference filter for sites. When filtering sites by conference purpose recent sites should appear, including the NSSHL site and the template site, both of which have been recently active and listed as a "conference".

I think this may be a bug in the search function?

conf filter.png (497 KB) conf filter.png Laurie Hurson, 2021-05-12 12:54 PM
conference filter example.mp4 (22.3 MB) conference filter example.mp4 Laurie Hurson, 2021-05-12 12:54 PM

History

#1 Updated by Boone Gorges 6 months ago

  • Category name set to Blogs (BuddyPress)
  • Status changed from New to Testing Required
  • Assignee set to Boone Gorges
  • Target version set to 1.18.10

Thanks for the report. I was able to track this down to a typo in the way that the Sites directory filter queries work. Fixed in https://github.com/cuny-academic-commons/cac/commit/78c3d9ffbeb76671ff844be77fa27dfa60f78b9f

For debugging purposes I needed to test on the production site, so the fix is live. Can you please confirm it before I close the ticket out?

#2 Updated by Laurie Hurson 6 months ago

Thanks, Boone.

Yes, the filtering by purpose>conference appears to be working correctly now. Thanks!

#3 Updated by Boone Gorges 6 months ago

  • Status changed from Testing Required to Resolved

Thanks for confirming!

Also available in: Atom PDF