Project

General

Profile

Bug #1463

Problems uploading PDFs to blog posts

Added by Sarah Morgano about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority name:
High
Assignee:
-
Category name:
WordPress (misc)
Target version:
Start date:
2011-12-17
Due date:
% Done:

0%

Estimated time:

Description

Hi,

A member reported problems uploading a PDF document into her blog using Windows XP with Chrome and Firefox, noting that she tried about a dozen times and somewhere between 20-70% she got a red error message. She was finally able to upload it with Firefox. I also tested with Windows 7/IE 9 and it gave me an "HTTP error message."

Best,
Sarah

1463.01.tiff (74.5 KB) 1463.01.tiff Boone Gorges, 2011-12-19 10:19 AM
flashuploader.jpg (65.4 KB) flashuploader.jpg Sarah Morgano, 2011-12-19 02:15 PM

History

#1 Updated by Matt Gold about 7 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to 1.3.1

#2 Updated by Boone Gorges about 7 years ago

  • Assignee changed from Boone Gorges to local admin
  • Priority name changed from Normal to High
  • Target version changed from 1.3.1 to Not tracked

André, can I ask for your feedback on this? I'm finding that I'm able to upload files up to about 300K before the request just hangs, and eventually times out. The strange thing is that I'm not getting an error in WP, which makes me think that it's not a PHP setting, but is a problem at the server level. Is there somewhere in the Apache config that might be blocking large incoming POST requests?

Strangely, I'm not experiencing the same problem on cdev, where I thought that we had the same config.

#3 Updated by local admin about 7 years ago

I was able to upload a 700kb PDF to a group normally. Will try a blog post now.

#4 Updated by local admin about 7 years ago

Yeah, I was able to upload this 700kb PDF to a blog post with no issues. Can I have more details on how to reproduce this? What browser etc.

#5 Updated by local admin about 7 years ago

  • Priority name changed from High to Normal

#6 Updated by Boone Gorges about 7 years ago

It's happening in every browser for me, both inside of groups and in blog Dashboards.

Do you have the ability to test from a non-GC IP? Would that make a difference?

#7 Updated by local admin about 7 years ago

Can you upload it to your media gallery? Yeah, I can try from an off-gc machine...

#8 Updated by Boone Gorges about 7 years ago

http://commons.gc.cuny.edu/wp-admin/media-new.php is one of the URLs where I had the problem.

#9 Updated by local admin about 7 years ago

Dude I'm getting a "Under maintenance" page now. Any idea?

#10 Updated by Boone Gorges about 7 years ago

I was upgrading the site. It's back open now.

#11 Updated by local admin about 7 years ago

Ah ok, cool. So I just uploaded a 3MB image via that link... Are you guys pulling my leg? ;)

#12 Updated by Boone Gorges about 7 years ago

  • File 1463.01.tiff 1463.01.tiff added
  • Assignee changed from local admin to Boone Gorges
  • Priority name changed from Normal to High

1463.01.tiff is a screenshot. The file I'm uploading is a 3.3MB PDF.

I'm going to try from another ISP later today and will report back if I find something out. I'll reassign to myself until I figure something out.

#13 Updated by Matt Gold about 7 years ago

Could the problem relate to whether one is working from within the GC network or not?

#14 Updated by Boone Gorges about 7 years ago

Could the problem relate to whether one is working from within the GC network or not?

I thought that André tested from a non-GC IP?

#15 Updated by local admin about 7 years ago

  • Assignee changed from Boone Gorges to local admin
  • Priority name changed from High to Normal

Ok, I see now it's a real error ;) yeah, I was able to reproduce it from the off-gc machine.

AFAIK there's no difference from the server POV if a request is coming from a gc sub-net or not but hey you never know, I'll look into it.

#16 Updated by Boone Gorges about 7 years ago

  • Priority name changed from Normal to High

Thanks, André.

I know you're busy, but this actually is fairly high-priority, as users tend to use file uploads quite frequently, and I anticipate an influx of support requests related to this. Thanks again for having a look.

#17 Updated by local admin about 7 years ago

Are there any debug fkags you could enable to help here? I'm having a hard time putting together what may have changed.

#18 Updated by Boone Gorges about 7 years ago

I'm having a hard time thinking of anything on the software end that would have caused this, or that you could use for debug - it seems like the problem is happening earlier than WP. WP itself isn't spitting out any errors - just timing out - so it's not clear what the break points would be.

Maybe I will write a quick HTML form that we can use for testing uploads from outside the WP environment. That may at least help to narrow things down. More to come.

#19 Updated by local admin about 7 years ago

Alright, test-driven approach all the way, man.

I'm still looking into it as well...

#20 Updated by Matt Gold about 7 years ago

Thanks to both of you for your work on this.

#21 Updated by Boone Gorges about 7 years ago

André, can you test this upload form, to see if you get a timeout? I'm tethering from my phone at the moment so I can't easily test big file uploads. http://commons.gc.cuny.edu/uploadtest.php

#22 Updated by local admin about 7 years ago

Marvellous, will do.

#23 Updated by local admin about 7 years ago

Can't upload with the test form either from off-gc, while it also works from here :-P

Still working on it though ...

#24 Updated by Boone Gorges about 7 years ago

Well, at least that rules out WP as the root cause of the problem.

Feel free to take that little PHP file and use it for your purposes. It might be worth setting up another vhost on the same machine using the default apache config, dropping that file into it, and testing at the new URL. That could narrow it down even a bit more.

#25 Updated by local admin about 7 years ago

Well, at least that rules out WP as the root cause of the problem.

WP is always already above suspicion! Impugnable and irrepressible, it is.

Feel free to take that little PHP file and use it for your purposes.

Wow, Christmas has come early this year ;)

It might be worth setting up another vhost on the same machine using the default apache config, dropping that file into it, and testing at the new URL. That could narrow it down even a bit more.

Thanks for the suggestion. Turns out the same problem seems to be taking place at ws.gc.cuny.edu as well!

#26 Updated by local admin about 7 years ago

I had a colleague here help me test from his home rig and he tells me it worked fine with >300kb files.

Can I ask you all to please try from different ISPs, machines, etc and post in what you get? I won't be able to test from home until I'm home myself.

Thanks!

#27 Updated by Sarah Morgano about 7 years ago

I just tested using Windows 7 / Firefox 8.0.1 and had no problems adding 755kb Word.Doc and 205kb PDF.

I also tested uploading these files using Windows 7 / IE 8.0.7 and I could upload without any problems using the "Browser uploader," but couldn't use the "Flash uploader" because the search box is not accessible (screenshot attached).

#28 Updated by Boone Gorges about 7 years ago

I've been doing a bit more testing, using the script at http://commons.gc.cuny.edu/uploadtest.php

- OS X 10.6.8, Firefox 8.0.1
- Time Warner Cable (Brooklyn)

I'm able to upload files up to about 90KB. Beyond that, it generally doesn't work.

But even below this 90KB point, it's spotty - sometimes the request will succeed, and sometimes I'll get a message "The connection to the server was reset while the page was loading." The frequency of this message seems to increase as the file size gets bigger. Interestingly, though, I've gotten this message once or twice in the last few weeks just during the normal course of browsing the Commons - normal GET requests. Refreshing the page always makes it work, so I never thought much of it, but it seems like they might be related.

André, could this be mod_security or something on that level? Can you glean anything useful from the access logs?

#29 Updated by local admin about 7 years ago

André, could this be mod_security or something on that level? Can you glean anything useful from the access logs?

I disabled mod_security for testing and nothing gets logged by httpd. The partial files get put into /tmp but not much more happens.

I hope it's not some esoteric network issue because some of our key network staff is off for the holidays.

#30 Updated by Boone Gorges about 7 years ago

  • Status changed from Assigned to Resolved

This seems to have been resolved; it looks like the problem had to do with GC network issues out of our control. Thanks to André for help debugging and following up.

Also available in: Atom PDF