Project

General

Profile

Bug #148

TinyMCE Problem with URLs in Posts

Added by Matt Gold over 12 years ago. Updated over 12 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2010-01-07
Due date:
% Done:

0%

Estimated time:

Description

When a URL is pasted into a post but not embedded through the link button, TinyMCE tries to format the link but winds up formatting it incorrectly. Please see this post for an example

History

#1 Updated by Boone Gorges over 12 years ago

Where did you get the URL to paste? From the address bar (where it was plaintext) or from somewhere else (where it might have already been a link)?

#2 Updated by Matt Gold over 12 years ago

I got it from the address bar in a Chrome browser.

#3 Updated by Boone Gorges over 12 years ago

I'm having a hard time reproducing your issue. Please make me a member of the CAT group so that I don't have to do it manually and so that I can see your problematic post.

#4 Updated by Matt Gold over 12 years ago

When I'm in the group admin screen and I select "send invites," I don't see your name listed among the members I can invite. And while there is a search box there, nothing gets pulled up through ajax when I start typing (and there is no submit button). So, I'm unable to invite you -- though can invite the boonesuper account.

#5 Updated by Boone Gorges over 12 years ago

Must have something to do with the fact that I'm a site admin. Will you invite teststudent?

#6 Updated by Matt Gold over 12 years ago

Test Student invited. but (just fyi), still no ajax (in the past, when I checked a name on the list, it appeared in the column to the right of the member listing. If you don't get the invite, please let me know.

#7 Updated by Boone Gorges over 12 years ago

ajax problem fixed. Please try resending to teststudent

#8 Updated by Matt Gold over 12 years ago

Nice work. I invited you instead of teststudent since your account came up on the ajax search.

#9 Updated by Boone Gorges over 12 years ago

I tried about twenty different things and I couldn't reproduce what's on that forum page. Would you mind trying to reproduce it yourself, in a private group, taking very careful note of the steps you take?

On an unrelated note, I just added a feature to the plugin that addresses your concern about links in email notifications. A link like <a href="http://google.com">Check out Google</a>, through the magic of regex, appears in the notification as Check out Google (http://google.com), and the url should automatically be linked in the email, depending on email client.

#10 Updated by Matt Gold over 12 years ago

When you have a chance, Boone, can you take a look at the post Luke put up on the LMS (Blackboard and Alternatives) group forum (http://commons.gc.cuny.edu/groups/lms-blackboard-and-alternatives)?

I notice a few things:

1. In the list of recently active forum topics, I see HTML anchor code

2. When the notification was emailed out, I didn't see the link formatted as you suggested it would in the note above (the post came through without any link).

Thanks for your attention to this; no rush, though.

#11 Updated by Boone Gorges over 12 years ago

  • Status changed from Assigned to Resolved

Closing this since the editor has been turned off.

Also available in: Atom PDF