Project

General

Profile

Bug #14821

PressForward plugin not working

Added by Rebecca Krisel 28 days ago. Updated 23 days ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Plugin Packages
Target version:
Start date:
2021-09-28
Due date:
% Done:

0%

Estimated time:

Description

Hello Ray!

I am writing in reference to the PressForward plugin on the GC Digital Initiatives website on the Commons (https://gcdi.commons.gc.cuny.edu).
We noticed a few different issues with the PressForward plugin:

  • Nominate This button is not working. It should open a pop up window prompting us to configure the details of the post. However, the pop up is not opening.
  • Can't open the recommended articles in the PressForward plugin in our dashboard

We think that this may be resolved by removing and then reinstalling/updating the plugin. Please could you take a look.

Thank you for your time!

Rebecca
GC Digital Fellow

History

#1 Updated by Boone Gorges 28 days ago

  • Status changed from New to Reporter Feedback

There were some problems in the way that CSS and JS assets were built in PressForward, which I've just fixed on the Commons. Can you see whether this fixes your problem?

If not, can you please share more details on how to reproduce the problem?

- In my tests, the Nominate This bookmarklet is opening the popup properly. If it's still not for you, please start by sharing your browser/OS combo so I can try to reproduce.
- I'm unsure what you mean by "the recommended articles in the PressForward plugin". Does this mean Dashboard > PressForward > Nominated? Please give detailed steps, including URLs, of what you're clicking and what you're expecting to see.

#2 Updated by Raymond Hoh 28 days ago

I was testing the Nominate This bookmarklet and it wasn't working for me, so I updated the pf_get_shortcut_link() function on production to better mirror the Press This bookmarklet code, which is the basis for the Nominate This bookmarklet: https://github.com/WordPress/press-this/blob/9ca88faabbf9e7eb6595a6b5da3b9120becf2ab6/press-this-plugin.php#L144-L150

So the bookmarklet should be working now. Just make sure you add the updated bookmarklet to your browser's Favorites bar. Boone, I've sent a pull request to the PressForward repo here.

I can confirm the second issue. Clicking on an article from the PressForward dashboard triggers an AJAX pf_ajax_relate request, but doesn't open the article. Can you take a look, Boone?

#3 Updated by Boone Gorges 27 days ago

  • Status changed from Reporter Feedback to Assigned
  • Assignee changed from Raymond Hoh to Boone Gorges
  • Target version set to 1.18.20

Thanks, Ray. I've merged your PR.

The second issue is due to changes in the Bootstrap library that PressForward ships with. I'll take time to look at this in the upcoming days.

#4 Updated by Boone Gorges 23 days ago

  • Status changed from Assigned to Reporter Feedback

I've addressed the Bootstrap compatibility issues and released PressForward version 5.2.8. This change is now live on the Commons. https://github.com/cuny-academic-commons/cac/commit/48b0295deb3d87cef33122af9a3bf7507964b633

Rebecca, are you able to test to see whether you're able to click through to read PF items as expected? Note that you might need to do a hard refresh (Shift + Refresh) to clear your browser's JS/CSS cache.

#5 Updated by Rebecca Krisel 23 days ago

Boone Gorges wrote:

I've addressed the Bootstrap compatibility issues and released PressForward version 5.2.8. This change is now live on the Commons. https://github.com/cuny-academic-commons/cac/commit/48b0295deb3d87cef33122af9a3bf7507964b633

Rebecca, are you able to test to see whether you're able to click through to read PF items as expected? Note that you might need to do a hard refresh (Shift + Refresh) to clear your browser's JS/CSS cache.

Boone Gorges wrote:

I've addressed the Bootstrap compatibility issues and released PressForward version 5.2.8. This change is now live on the Commons. https://github.com/cuny-academic-commons/cac/commit/48b0295deb3d87cef33122af9a3bf7507964b633

Rebecca, are you able to test to see whether you're able to click through to read PF items as expected? Note that you might need to do a hard refresh (Shift + Refresh) to clear your browser's JS/CSS cache.

Yes, I can click through the PF items and the Nominate Button seems to work! Thank you!

#6 Updated by Boone Gorges 23 days ago

  • Status changed from Reporter Feedback to Resolved

Thanks so much for confirming!

Also available in: Atom PDF