Project

General

Profile

Bug #149

Email Notifications and TinyMCE

Added by Matt Gold over 12 years ago. Updated over 12 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2010-01-07
Due date:
% Done:

0%

Estimated time:

Description

I've noticed two problems with forum posts mailed out after being formatted with TinyMCE:

  • Paragraphs are not formatted correctly in the emailed versions. I see line breaks but not blank lines between paragraphs, so a multi-paragraph message looks like one paragraph of text.
  • I see non-breaking space html special characters ( ) in the message. I will forward my notification message to you.

History

#1 Updated by Boone Gorges over 12 years ago

  • Status changed from Assigned to 3

Both fixed. Please test.

#2 Updated by Matt Gold over 12 years ago

Perfect. Thanks, Boone. I do notice that when I hit "enter" to start a new paragraph, the new paragraph is indented from the previous one. This creates a nested effect -- each new paragraph starts off a little more indented than the previous one. Not a big deal, but maybe worth looking into.

#3 Updated by Boone Gorges over 12 years ago

You're experiencing this everywhere? Forums and wire? I can't reproduce it. (Even if I could, sounds like a TinyMCE problem and probably more trouble than it's worth to troubleshoot.)

The HTML output of TinyMCE looks fine to me. And p tags don't nest anyway (the close tag is implied).

#4 Updated by Matt Gold over 12 years ago

  • Status changed from 3 to Resolved

I experienced it once but didn't retest. Agree that it's more trouble than it's worth for me to retest or you to debug.

Thanks for your work on this.

#5 Updated by Matt Gold over 12 years ago

  • Status changed from Resolved to Assigned

Reopening. Please see email regarding paragraph formatting.

#6 Updated by Boone Gorges over 12 years ago

  • Status changed from Assigned to 3

It appears that this was caused by the user pasting in text that was composed in another application. Thus it didn't adhere to TinyMCE's HTML formatting. I have added additional filters that should solve most problems like this in the future.

#7 Updated by Matt Gold over 12 years ago

  • Status changed from 3 to Resolved

Thanks for this, Boone.

Also available in: Atom PDF