Project

General

Profile

Bug #15175

"Load More" button not working correctly on a user's "Commons Profile > Activity" page

Added by Raymond Hoh 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2022-01-11
Due date:
% Done:

0%

Estimated time:

Description

While looking into #15152, I discovered that the "Load More" button was not working correctly when on a user's "Commons Profile > Activity" page. The problem is the pagination could be using the wrong page offset and the loading GIF was not showing up when clicking on the button.

The problem is in our bp-nelo theme, the JS selectors for the News / My Commons page and a user's "Commons Profile > Activity" page are different. We need to ensure that the selectors are the same for both pages. As for the pagination bug, we have to port the following fix over from the BuddyPress bp-legacy template pack: https://buddypress.trac.wordpress.org/changeset/12181.

Fix coming shortly.

History

#1 Updated by Raymond Hoh 4 months ago

  • Status changed from New to Staged for Production Release

#2 Updated by Boone Gorges 4 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF