Project

General

Profile

Bug #1531

Commons Only Viewable to Logged-In Viewers

Added by Matt Gold about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2012-01-11
Due date:
% Done:

0%

Estimated time:

Description

Saw the attached screenshot when I visited the Commons. Will investigate the backend pronto but wanted to let you know, too. Wondering why/how this happened.


Related issues

Related to CUNY Academic Commons - Bug #1259: Homepage redirectResolved2011-10-23

History

#2 Updated by Matt Gold about 10 years ago

Privacy settings don't look like they used to (part of WP update, I guess) -- no way to choose "I want my site to be visible to everyone." Is that a default choice only overridden when something else is checked? Should we have "More Privacy Options" enabled on the main blog?

#3 Updated by Boone Gorges about 10 years ago

  • Target version changed from Not tracked to 1.3.4

I don't know how it happened, though this ticket is a duplicate of #1259. In that ticket, I wrote a function that was supposed to protect the main blog's privacy setting from being set to anything other than public, but apparently something is bypassing it.

I'll write something else that tries to prevent it.

#4 Updated by Boone Gorges about 10 years ago

Privacy settings don't look like they used to (part of WP update, I guess) -- no way to choose "I want my site to be visible to everyone."

WP changed the wording. The first option ("allow search engines...") is the same as the old public option.

Should we have "More Privacy Options" enabled on the main blog?

More Privacy Options is in mu-plugins, so it is enabled on the main blog. That's where the extra three options on the Privacy panel come from - WP only comes with two options.

#5 Updated by Matt Gold about 10 years ago

Just want to reiterate the urgency of this ticket, as the site is currently available only to Commons members.

#6 Updated by Boone Gorges about 10 years ago

That's not true. I'm able to access it as a non-logged-in user. I figured you'd switched it back.

#7 Updated by Boone Gorges about 10 years ago

Actually, for some reason, I'm able to access any page, consistently, as a non-logged-in user, but as soon as I hit the 'refresh' button, I get the login message. Working on it.

#8 Updated by Matt Gold about 10 years ago

Thanks. Was upstairs in another person's office and wanted to show him something on the Commons, which is when we ran into the log-in issue (ie., on a different computer than the one I had been using previously)

#9 Updated by Boone Gorges about 10 years ago

  • Status changed from Assigned to Resolved

There's no way for me to tell what's causing the problem. As I guess in #1259, it's probably bp-groupblog, but I still can't see what it is about bp-groupblog.

So I'm left with the somewhat more brute force method of ensuring that the main blog's privacy level is always read as 1, even if someone sets it to something else (like -2, in this case). My fixes for #1259 worked in most cases. But More Privacy Options had a certain set of cases where my fix didn't come early enough in the chain. In fact, there is no place in the WordPress loading process, between the time when the $current_blog item is first loaded and when MPO does its stuff, where I can reliably hook and force the value of blog_public to 1. So I've taken the even more brute force method of modifying the MPO plugin so that it ignores blog #1. See https://github.com/castiron/cac/commit/063520cc297277a7b82bf8242e1f8902f3e2293a

Seems to be working properly now.

#10 Updated by Matt Gold about 10 years ago

Thanks for taking care of this, Boone. I tend not to condone brute force, but in this case, it seems justified!

Also available in: Atom PDF