Project

General

Profile

Bug #1555

Sticky forum post shows up twice in post listings

Added by Matt Gold over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-01-18
Due date:
% Done:

0%

Estimated time:

Description

Just created a sticky post in the CAC project group. It seems to show up twice in the listings. Tried to un-stick one of them, but that made both posts disappear.

History

#1 Updated by Boone Gorges over 10 years ago

Congratulations on what is, I believe, your first ever use of the Low priority! :)

#2 Updated by Matt Gold over 10 years ago

That is so not true!! And I actually take pride in my reluctance to escalate ticket priority, which I like to think shows my great sense of perspective and restraint, as well as an ability to stay cool-headed in the face of the kinds of crises that would throw others into reckless uses of the immediate/urgent ticket priorities. At the very least, you've got to give me that -- I rarely, if ever, use those settings.

#3 Updated by Matt Gold over 10 years ago

Just noticed this again on another group. Screenshot attached.

#4 Updated by Boone Gorges over 10 years ago

  • Status changed from Assigned to Resolved

This is caused by some custom code introduced long ago to correct the way that sticky topics are displayed. I have since rewritten the sticky logic in BuddyPress (a formidable feat of logic that took me a few days! http://buddypress.trac.wordpress.org/changeset/4764), so that the old custom code became redundant. I have removed it in https://github.com/castiron/cac/commit/0224cfd11f413588cb650e18a5a883e037a397d6

#5 Updated by Matt Gold over 10 years ago

Awesome. Thanks, Boone.

Also available in: Atom PDF