Project

General

Profile

Bug #1609

problem inviting members to hidden group

Added by Michael Mandiberg over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-02-02
Due date:
% Done:

0%

Estimated time:

Description

I am not sure if this is user error or a bug. I have invited 8 new members to the private/hidden Core 2 group, and none of them have joined. One of them contacted me to find out what was up, and I asked her to look for her invitation (which comes under notifications, right?). She had no notifications. Is she not looking in the correct place, or is this an error? I searched the help files for information on this, but couldn't find any clear documentation about where invitations go (and don't remember the last time I was invited clearly)

I will be using the group tonight for my seminar, starting at 415. So this is kind of rushed/important. Sorry.

History

#1 Updated by Matt Gold over 9 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to 1.3.6

#2 Updated by Boone Gorges over 9 years ago

  • Status changed from Assigned to Reporter Feedback

Not sure why notifications are not appearing, but in any case users should be able to access their group invitations at http://commons.gc.cuny.edu/members/[username]/groups/invites/. Navigate there: your profile > Groups > Invitations (tab)

Have one of your students try this. If the invitations are found there, then there may be a notification bug. If the invitations are not found there, then it's an invitation bug.

#3 Updated by Matt Gold over 9 years ago

Thanks for your quick attention to this, Boone.

#4 Updated by Michael Mandiberg over 9 years ago

I asked a different student to confirm if they had any notifications and if they could see the invite in their member/user/groups/invites and confirmed a NO on both. So it is an invitation bug.

Thanks for you help on this!

#5 Updated by Michael Mandiberg over 9 years ago

One more update:

I was able to successfully sign user up by having them go here

http://commons.gc.cuny.edu/groups/itp-core-2-2012/

and request membership

we will use this workflow for the course signup, so crisis averted.

bug seems to be reproduceable, though

tx all

m

#6 Updated by Boone Gorges over 9 years ago

  • Status changed from Reporter Feedback to Assigned

Thanks for adapting, Michael. I'll try to pin down the issue.

#7 Updated by Boone Gorges over 9 years ago

  • Status changed from Assigned to Reporter Feedback

Hm...I can't reproduce this. In a hidden group, I sent an invitation to another user. That user received an email notification, and when I logged in as that user and navigated to user > groups > invites, the invitation was there. Am I correct that this is the method you followed?

If so, it's possible that there is a specific problem with your group. Michael, are there any students whom you originally invited to the group who have not yet joined it via your workaround? If so, I could dig into the database to see if I can get a sense of what may have gone amok.

#8 Updated by Matt Gold over 9 years ago

Any chance that this could be a browser caching issue -- ie., maybe the new notification really was there for Michael's students and would have shown up had they done a hard refresh on the page, but that they were actually looking at a cached version of the page? If so, perhaps we should discuss what browser/os configurations are being used in these cases.

#9 Updated by Michael Mandiberg over 9 years ago

All have joined. I can confirm that none of them saw the notification, so it would have to be that all of them had caching issues. There have been caching issues I have experienced with the CAC previously. See comment 3 here: http://redmine.gc.cuny.edu/issues/1536#change-5716

#10 Updated by Boone Gorges over 9 years ago

  • Target version changed from 1.3.6 to 1.3.7

#11 Updated by Boone Gorges over 9 years ago

  • Target version changed from 1.3.7 to 1.3.8

#12 Updated by Boone Gorges over 9 years ago

  • Target version changed from 1.3.8 to 1.3.9

#13 Updated by Michael Mandiberg over 9 years ago

Just wanted to say I continue to have caching issues w/ the CAC. Very strange ones where I am logged in, then I am not. I re log in, and still am not logged in.... SO it seems on one level that cache is the likely culprit BUT all 8 of the invitees had no invite... 8 of 8 users all having cache issues?

BTW, why is the CAC so cache-funky?

#14 Updated by Boone Gorges over 9 years ago

why is the CAC so cache-funky?

Don't know. I've had similar problems, though usually it's not actually the case that I get logged out - instead, it just looks like I'm logged out, and then when I refresh the page, I find I'm actually logged in. (So the problem is cache-based, rather than cookie-based.) It appears to be a problem with Firefox only. I've spent hours trying to track it down, but to no avail, yet.

In any case, I'm skeptical that this same cache issue is at the root of the group invitation problem you describe (though it's possible, I suppose). I'll continue to try to reproduce your problem - so far I have not been successful, which makes it difficult to actually track down the bug.

#15 Updated by Matt Gold over 9 years ago

Hi Boone,

FWIW, I continue to experience caching issues on Chrome and have had other people confirm to me that they have, too. A refresh always fixes things, but most users don't know that they could/should do that. Probably fodder for a separate ticket.

Best,

Matt

#16 Updated by Michael Mandiberg over 9 years ago

I have had cache issues which have not been solved by a shift refresh. I usually have to switch browsers. Can't remember which, but most likely happened in FFX and switched to Saf or Chrome. Next time it happens I will document for you.

#17 Updated by Boone Gorges over 9 years ago

  • Target version changed from 1.3.9 to 1.3.10

#18 Updated by Boone Gorges over 9 years ago

  • Status changed from Reporter Feedback to Rejected

As I'm unable to reproduce the ghost-invite issue, either on the Commons or on any other BuddyPress installation, I'm going to close this ticket. (Not that I don't believe you, Michael, I'm just cleaning up in here!) If any new information arises - and especially if this happens again on the Commons and you let me know about it before getting the members into the group some other way - let's reopen the ticket at that point.

#19 Updated by Michael Mandiberg over 9 years ago

seems prudent. if it happens again, i will clue you in before any workarounds

#20 Updated by Matt Gold over 9 years ago

Thank you, Michael.

Also available in: Atom PDF