Project

General

Profile

Actions

Bug #16606

closed

"Edit Content" Area in Make theme Builder template not closing

Added by Laurie Hurson about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Themes
Target version:
Start date:
2022-08-12
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

A faculty member writes:

"I was trying to edit one of my pages today and every time the Edit Content dialog box would freeze. You can add or edit content, but the dialog box would not go away. Also, there were no Visual/Text tabs. I have tried several times since morning with the same effect. What should I do?"

Screenshot of make content are attached.

The site in question is: https://phil2101bcmgluzman.commons.gc.cuny.edu

I was able to recreate the issue on the site; when I try to edit a content area on a page I get the edit content modal but it will not close when i click the "X"

This may be a bug with the make theme but it also may be a weird interaction/bug caused by plugins running on the site.

Thanks!


Files

make content bug.png (336 KB) make content bug.png Laurie Hurson, 2022-08-12 08:29 AM
Actions #1

Updated by Boone Gorges about 2 months ago

  • Status changed from New to Reporter Feedback

I've traced the problem to an incompatibility between the Make theme and the WP-Markdown plugin. wp-markdown removes the Visual tab for users by filtering 'user_can_richedit'. The latter filter wreaks havoc with much of WP, since WP is no longer able to load the TinyMCE scripts. Make, in turn, doesn't have graceful fallbacks when TinyMCE is not available. So it's a shortcoming in both the theme and the plugin.

For the time being, I've disabled WP-Markdown on the site. In the future, the user might consider deactivating that plugin permanently, or else deactivating it only when there's a need to use the Make Builder feature, then reactivating.

Actions #2

Updated by Marilyn Weber about 2 months ago

Thanks, Boone! Will let her know.

Actions #3

Updated by Marilyn Weber about 2 months ago

She reassures "I will not reactivate the plugin. I don’t really need it for the site to run."

Actions #4

Updated by Boone Gorges about 1 month ago

  • Category name set to WordPress Themes
  • Status changed from Reporter Feedback to Resolved
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

Excellent - thanks for reporting back!

Actions

Also available in: Atom PDF