Project

General

Profile

Feature #169

Enable Plugins to Be Activated on a Selective Basis

Added by Matt Gold over 12 years ago. Updated almost 12 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
-
Start date:
2010-03-02
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,

I'd like us to figure out how to enable plugins on a user-by-user basis. This will allow us to vet certain advanced users and to make potentially dangerous plugins, like unfiltered MU (which I happen to need for the News blog right now, but which I don't want to enable on a site-wide basis) available to those users.

I seem to remember that Luke knows how to do this if you want to check in with him.


Related issues

Is duplicate of CUNY Academic Commons - Feature #296: Selective plugin activationResolved2010-08-20

History

#1 Updated by Boone Gorges over 12 years ago

I talked to Luke and he said that they don't really have a great system. Perhaps the most viable option is to turn off the plugin page for most users, use Plugin Commander to limit availability of plugins to those that are safe for everyone, and have one of the admins activate other plugins on a case-by-case basis.

#2 Updated by Matt Gold over 12 years ago

Thanks for speaking to Luke, but I'm loathe to depend on Plugin Commander -- I've found it to be a little unreliable in the past. Maybe we should wait on this . . . . hmmmm.

#3 Updated by Boone Gorges almost 12 years ago

  • Status changed from Assigned to Duplicate

Duplicate of #296

Also available in: Atom PDF