Project

General

Profile

Actions

Bug #17346

closed

Custom Sidebars plugin shows 'not compatible' notice

Added by Boone Gorges 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Plugins
Target version:
Start date:
2022-12-07
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

The Custom Sidebars plugin is, as of a recent update, showing a notice indicating that the plugin is not compatible with Block widgets. It then asks users to install Classic Widgets instead. See https://redmine.gc.cuny.edu/attachments/24131

I haven't looked into the compatibility issue, but the problem with the widget is that it tells the user to install a plugin. (a) Users can't install plugins on CAC, and (b) Classic Widgets is already installed. Instead, it should ask the user to activate the plugin.

I really dislike modifying the notices created by plugins - these mods almost always become obsolete very quickly - but in this case I think we should consider either (a) removing the notice altogether, or (b) modifying the notice content somehow so that it asks users to perform the correct action.


Related issues

Related to CUNY Academic Commons - Support #17314: category link problemsNew2022-11-30

Actions
Actions #1

Updated by Boone Gorges 2 months ago

Actions #2

Updated by Boone Gorges about 2 months ago

  • Target version changed from 2.0.13 to 2.0.14
Actions #3

Updated by Boone Gorges about 1 month ago

  • Status changed from New to Staged for Production Release

Here's what I mean when I suggest that removing/modifying these sorts of notices is fragile: https://github.com/cuny-academic-commons/cac/commit/5c97fe34b4e71b94a471790cb85f920b8b655896

Actions #4

Updated by Boone Gorges about 1 month ago

  • Status changed from Staged for Production Release to Resolved
Actions

Also available in: Atom PDF