Project

General

Profile

Support #1891

Question about PDF file names

Added by Matt Gold about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2012-05-14
Due date:
% Done:

0%

Estimated time:

Description

Someone who published an article in Zeteo (which publishes PDFs rather than publishing directly onto pages) writes about a problem accessing the file from a google search:

"To clarify the issue with my article: If you go through the zeteo website it's fine. The problem is if you try to look up the article on its own. If you type "virginia woolf physics" in any search engine, it will pull up the link directly to the article, but when you click on it the link will say "link broken" or "file not found." So if anyone is searching for an article about Woolf and physics, they will find the link to mine but won't be able to see it."

Attached is a screenshot of what comes up when you do the google search suggested above. Thoughts?

History

#1 Updated by Boone Gorges about 7 years ago

  • Status changed from Assigned to Reporter Feedback

It looks like Google has indexed the incorrect URI for the PDF. I'm guessing that's because it was uploaded once (in Nov 2011, as per the indexed URI) and then replaced (in May 2012, as per the live URI). So Google's index points to an out-of-date URI.

Google will, I presume, fix this over time. (Google indexes things pretty quickly, so I wouldn't be surprised if it fixed itself in the next couple days. I submitted an index request to Google http://www.google.com/addurl/?continue=/addurl but it's really out of my hands.

If this is critical issue, I can manually write .htaccess redirects for the specific files in question, though I would rather not set a precedent of doing this.

#2 Updated by Matt Gold about 7 years ago

  • Status changed from Reporter Feedback to Resolved

No worries -- I'll advise them to submit the corrected link to google.

#3 Updated by Matt Gold about 7 years ago

D'oh -- just saw you already did that. Thanks, Boone.

Also available in: Atom PDF