Project

General

Profile

Bug #1916

Images Breaking on Help Blog and Ground Control

Added by Matt Gold almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2012-05-24
Due date:
% Done:

0%

Estimated time:

Description

Possibility related to timthumbs, we're seeing broken images on Ground Control and the Help Blog:

http://help.commons.gc.cuny.edu/

http://groundcontrol.commons.gc.cuny.edu/

History

#1 Updated by Boone Gorges almost 10 years ago

Yes, this is a TimThumb problem. There is no way for me to do a global override of TimThumb cache directories, so I'm either going to have to modify TimThumb in every Woo theme, or I'm going to have to create all of the cache directories manually and give them extremely lax permissions. Both solutions are awful, but I don't see any way around it. For the moment, I've fixed the themes running on Ground Control and the News blog, and I'll think about whether there's a better solution more generally.

#2 Updated by Matt Gold almost 10 years ago

Thanks. I suppose that we should think about removing themes that have/cause this problem -- at least ones that aren't being used widely.

#3 Updated by Matt Gold almost 10 years ago

  • Priority name changed from Normal to High

Just heard from Maura that this is affecting the games blog, too (http://games.commons.gc.cuny.edu/), so I am raising the priority of the ticket.

#4 Updated by Boone Gorges almost 10 years ago

I've manually fixed the issue for the Games site. I'm still exploring solutions. (As much as I would like to remove all Woo themes, it's not very practical.)

#5 Updated by Matt Gold almost 10 years ago

Thanks, Boone. Any way you or Dom could see which other sites are using the same theme (using the Theme Stats tool) and then applying the fix to them, too?

#6 Updated by Boone Gorges almost 10 years ago

As I mentioned, I would like to come up with a real solution for this, other than the hacks (and they are true hacks) that I have been implementing. The several hours that would be spent hacking through every one of these themes would be better spent coming up with a real solution. The issue is marked High priority, and as such I will try to figure something out as soon as I can.

#7 Updated by Maura Smale almost 10 years ago

Thanks Boone!

#8 Updated by Matt Gold almost 10 years ago

Great -- thanks, Boone.

#9 Updated by Boone Gorges almost 10 years ago

  • Status changed from Assigned to Resolved

I have put a hotfix into place that does the following:
- creates a TimThumb config file at wp-content/timthumb-config.php, which contains a new definition of FILE_CACHE_DIRECTORY
- creates symlinks in each Woo theme to this config file

Looks like images are now working on WooThemes-powered sites. See https://github.com/castiron/cac/commit/2e9e4ecd57b97e77ec1fa0a7fcb5ce9a99f82804 https://github.com/castiron/cac/commit/ec40d463cff644d9b9854ecbeaa98f3a94617b8b https://github.com/castiron/cac/commit/0df37e5e757ae0894807e1498927072f885091a8

#10 Updated by Matt Gold almost 10 years ago

Great -- thanks, Boone.

Also available in: Atom PDF