Project

General

Profile

Bug #1951

Check RSS feed of GCDI site

Added by Matt Gold almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2012-06-19
Due date:
% Done:

0%

Estimated time:

Description

We've had a report that the RSS feed for the GCDI site (http://gcdi.commons.gc.cuny.edu/) isn't working. This is from Chris Caruso, who is working on the ARC site (http://research.commons.gc.cuny.edu/) and is trying to incorporate the feed.

History

#1 Updated by Matt Gold almost 7 years ago

Just FYI, I've made Chris a watcher on this ticket.

#2 Updated by Boone Gorges almost 7 years ago

  • Status changed from Assigned to Reporter Feedback

Chris - Can you provide more details on how it's not working? The feed appears mostly valid to me - the one warning being thrown by the validator has to do with iframes being included in the content.

#3 Updated by Chris Caruso almost 7 years ago

Check out our sandbox site here: http://www.humanrightstech.org/sandbox/ This is the test site for http://research.commons.gc.cuny.edu/. I'm pulling in headlines from the various ARC project feeds with WP-RSSImport.

The http://gcdi.commons.gc.cuny.edu/feed/ feed is working better now than when I first reported the problem. It still does occasionally return a "No items, feed is empty." message, but is mostly working now.

#4 Updated by Boone Gorges almost 7 years ago

Thanks for the additional details, Chris.

Given what you've described, one of two things are happening. (1) The plugin is unable to access the feed at all, either because of network issues (like maybe your sandbox is behind a particular kind of firewall) or because of hiccups on the Commons end. (2) Occasionally, an item moves through the GCDI feed with something like an

<iframe>
or some kind of invalid markup, which is, in turn, causing WP-RSSImport's feed parser to fail completely.

I'm testing out the WP-RSSImport widget on a Commons sandbox, and it seems to be parsing the feed items correctly from http://gcdi.commons.gc.cuny.edu/feed/. So it's possible that you're using a particular configuration of the RSSImport widget that is surfacing the issue. But there are so many options on the widget that I don't want to try to guess which could be the culprit :)

Since your sandbox is not on the Commons, it's hard for me to do any live debugging in an environment that's demonstrating the problem. Can I ask you to create a new private site on the Commons, activate WP-RSSImport, and set up the GCDI feed widget in the same way you have it set up in the sandbox? (No need to worry about the theme or the rest of the configuration - I'm pretty certain that those things are not relevant.) Then, let me know whether your new sandbox is demonstrating the problem. If it is, then I can debug more effectively. And if not, we can check periodically to see if it does fail in the future, at which point I can dig in.

Thanks in advance for your help.

#5 Updated by Matt Gold almost 7 years ago

I agree that it would be best to have the sandbox install in the same environment as the production site. Thanks, Chris and Boone.

#6 Updated by Boone Gorges almost 7 years ago

I agree that it would be best to have the sandbox install in the same environment as the production site.

I'm not really suggesting this - if Chris needs to be editing the theme and otherwise accessing the codebase, then it won't work to have the sole sandbox on the Commons. But for reasons such as the problem reported in this ticket, it's important to test in the production environment at at least some point in the process.

#7 Updated by Matt Gold almost 7 years ago

Good point.

#8 Updated by Chris Caruso almost 7 years ago

Thanks, Boone. Makes sense. I set up a test page on the Commons here:

http://chriscaruso.commons.gc.cuny.edu/2012/06/25/rss-test/

And everything seems to work fine.

I wasn't able to do an ARC sandbox on the Commons because I needed the Advanced Excerpt plugin to be able to display RSS titles properly in the particular theme we are using for ARC. But you are right that the proper way to test the RSS feeds is on the Commons. So since this seems to work fine, I think we are all set to update to the new RSS features for the ARC page with the next Commons release.

Thanks again for your help.

#9 Updated by Boone Gorges almost 7 years ago

  • Status changed from Reporter Feedback to Rejected

Hi Chris - Thanks very much for setting up that sandbox on the Commons. I'm still a bit unsure as to why it's not working on your dev environment, but I'm glad to see that it's working on the Commons! Let's keep an eye on this - feel free to reopen this ticket if the problem arises in the production environment.

#10 Updated by Matt Gold almost 7 years ago

Hi Chris,

Just FYI, the privacy setting on your Commons dev environment looks like it is set to fully public, so your blog feed is showing up on the home page of the Commons. If you choose any other privacy setting, it won't show up in the sitewide feed. Not a big deal, but just wanted to give you a heads-up.

Best,

Matt

#11 Updated by Chris Caruso almost 7 years ago

Okay, thanks. I changed the privacy setting to 'admins only'.

Chris

#12 Updated by Chris Caruso almost 7 years ago

I've incorporated the RSS feeds into the front page of the live ARC site here:

http://research.commons.gc.cuny.edu/

And the GCDI RSS feed still has intermittent problems. It sometimes (but not always) produces the error "No items, feed is empty.…" instead of displaying the feeds. Usually a simple browser refresh solves the problem, but I have some concerns about first impressions. None of the other feeds I am pulling seem to be having problems. Thanks for any help.

#13 Updated by Boone Gorges almost 7 years ago

  • Status changed from Rejected to Reporter Feedback
  • Target version changed from 1.3.15 to 1.3.17

Hi Chris,

Thanks for the update. Having the problem reproduced on the Commons was very helpful.

I spent some time with RSSImport and found that the shortcode defaults to using a deprecated version of WordPress's RSS-parsing library. It appears as if performance is much better if you force the plugin to use the newer SimplePie instead. You can do that by adding the use_simplepie="1" attribute to the shortcode, like this:

[RSSImport display="2" feedurl="http://gcdi.commons.gc.cuny.edu/feed/" use_simplepie="1"]

I did this for the GCDI feed, and it seems to do the trick quite nicely - I can't get it to reproduce the error anymore. Give it a try with the rest of the feeds, and let me know if you notice a difference.

#14 Updated by Matt Gold almost 7 years ago

Nice detective work, Boone -- many thanks.

#15 Updated by Chris Caruso almost 7 years ago

Genius! Thanks so much. I've updated the other feeds as well.

#16 Updated by Boone Gorges almost 7 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version changed from 1.3.17 to Not tracked

Excellent! I'm going to mark this Resolved. Chris, please let me know if you experience further problems.

Also available in: Atom PDF