Project

General

Profile

Bug #1976

Sending Invites Through Email

Added by Sarah Morgano over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-07-02
Due date:
% Done:

0%

Estimated time:
2.00 h

Description

Hi Boone,

I'm not really sure how to test this or if this is really an issue, but within the past week or so a couple of members reported problems sending group invites to non-register users. I haven't received much feedback in terms of additional details, but today a member noted was able to send invites to 5 members . However, when he tried to add more than 5 at a time he received an error message. Is there a max amount that can be entered at a time?

Thanks,
Sarah

error.png (163 KB) error.png Sarah Morgano, 2012-07-11 11:33 AM

History

#1 Updated by Matt Gold over 9 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Target version set to 1.3.17

#2 Updated by Boone Gorges over 9 years ago

  • Status changed from Assigned to Reporter Feedback

Is there a max amount that can be entered at a time?

Yes, 5. The reason is that we don't want the Send Invites page to become a spam machine.

I'm happy to do one or both of the following:
(a) Raise the limit
(b) Add an inline note to the effect of "Max five at a time"

#3 Updated by Matt Gold over 9 years ago

I'll play Solomon: let's raise the limit to seven and alert users to the limit with a note.

#4 Updated by Sarah Morgano over 9 years ago

That sounds like a good idea. I'll email the member and let him know about the limit.

#5 Updated by Sarah Morgano over 9 years ago

  • Status changed from Reporter Feedback to Assigned

Hi guys,

I wanted to update this ticket because the issue seems to be that the invite counter does not reset to zero after the first 5 are sent. He is still receiving a message saying that he can invite 0 people. Could this perhaps be a browser issue, he is using Google Chrome.

Best,
Sarah

#6 Updated by Boone Gorges over 9 years ago

  • Status changed from Assigned to Reporter Feedback

I've changed the max number of simultaneous invitations to 7. In https://github.com/castiron/cac/commit/474134220ca125092cab78375d3c69def4a07d41, I add a message that explains this on the front end.

the issue seems to be that the invite counter does not reset to zero after the first 5 are sent.

I'm not able to reproduce this. There's no persistent limit - the limit of 5 (7 now) only applies to a single form submit. It's possible that the user is doing something strange with the back button, etc. Can I get exact steps to reproduce, and the text of the exact error as it appears on the screen?

#7 Updated by Sarah Morgano over 9 years ago

Hi Boone,

Before I reach back out to him, he was using Google Chrome. Could it perhaps be a browser issue?

Best,
Sarah

#8 Updated by Sarah Morgano over 9 years ago

Sarah Morgano wrote:

Hi Boone,

Before I reach back out to him, he was using Google Chrome. Could it perhaps be a browser issue?

Best,
Sarah

Just realized that I included this above, so it's obviously not a browser issue. I will update this ticket again when I hear back from the member. = )

#9 Updated by Sarah Morgano over 9 years ago

Hi Boone,

Here's what Ray wrote back just now:

I clicked on Send invites, and then on the link that says to email persons not registered to the site, I entered a person’s email, the sixth one ever, and then I get the message below in the screen capture. This happens in both Chrome and IE.

Best,
Sarah

#10 Updated by Boone Gorges over 9 years ago

  • Status changed from Reporter Feedback to Hold

I'm still not able to reproduce the issue, strangely enough. But I did find a place in the codebase where such a problem might be occurring. I've fixed it in https://github.com/castiron/cac/commit/9bdf09cebc014fd738574e46b14c05ab6a62d263.

Sarah, when this fix goes live (probably later today - follow http://dev.commons.gc.cuny.edu for 1.3.17 to be released), could you contact the member to see if the problem has been cleared up? Thanks.

#11 Updated by Boone Gorges over 9 years ago

Hi Sarah. The 1.3.17 release is now live.

#12 Updated by Sarah Morgano over 9 years ago

  • Status changed from Hold to Assigned
  • Priority name changed from Normal to High
  • Target version deleted (1.3.17)

Hi Boone,

Another member just reported the same issue (see below):

I'm trying to send invites to other staff members in CUNY to join the Academic Commons and our group 'HR Recruiting Network' but the site is not allowing me to invite anyone. The message keeps telling me that

Some of your invitations were not sent. Please see the errors below and resubmit the failed invitations.
1. You are only allowed to invite 0 more people. Please remove some addresses and try again

Since the member is trying to invite folks to a hidden group, she can't just send an email with the link. If this issue cannot be resolved quickly, is there another workaround to get these folks over to the hidden group?

Best,
Sarah

#13 Updated by Matt Gold over 9 years ago

  • Target version set to 1.4.3
  • Severity set to Normal

#14 Updated by Boone Gorges over 9 years ago

  • Priority name changed from High to Urgent
  • Estimated time set to 2.00 h

#15 Updated by Boone Gorges over 9 years ago

  • Status changed from Assigned to Resolved

Sarah, I managed to find the bug. Fixed in https://github.com/castiron/cac/commit/ef3bd19efeaa5f5562abcb2aa15070edb4755bdd

Because I had to troubleshoot this on the live site to reproduce the issue, the fix is already live.

#16 Updated by Sarah Morgano over 9 years ago

Thanks, Boone. I will let her know.

Also available in: Atom PDF