Project

General

Profile

Bug #1977

Older posts appearing in activity stream

Added by Sarah Morgano about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-07-03
Due date:
% Done:

0%

Estimated time:

Description

Over the past week I've noticed some older posts creeping back in the activity stream. For example Lee's post "Learn Greek, Support Open Access" is currently appearing on the homepage, but was published back in May. Do you know if this is a bug or perhaps something related to the users updating blog posts?

blog_activity.jpg (140 KB) blog_activity.jpg Sarah Morgano, 2012-07-03 11:40 PM

History

#1 Updated by Matt Gold about 9 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to 1.3.17

Sarah -- I'm not seeing this. Can you provide a screenshot? And are you seeing this as a logged-in or logged-out user?

#2 Updated by Sarah Morgano about 9 years ago

Hi Matt,

It looks like a recent blog post pushed Lee's post off the homepage, but here's a screenshot of the news activity feed with the blog posts filter. It's the same view as both a logged-in and logged-out user. Also, I noticed that Lee wrote a new post directly before the old one appeared. Another odd observation was that Brian's latest round-up post appeared directly after it, and it had already appeared in the activity feed yesterday.

Best,
Sarah

#3 Updated by Boone Gorges about 9 years ago

Sarah, can you please clarify what's wrong with the screenshot? What are you seeing that you don't expect to be seeing?

#4 Updated by Sarah Morgano about 9 years ago

Hi Boone,

I am seeing a couple of posts that appear to be out of place in the activity stream. Lee's post about open access is from May and Brian's post was from yesterday, not 7 hours ago. It may be because they updated the post, but it looked odd and I wasn't sure if it was a bug or not.

Best,
Sarah

#5 Updated by Boone Gorges about 9 years ago

  • Status changed from Assigned to Resolved

Thanks for the details, Sarah.

I've verified that in the cases you've referenced, the issue is that the blog post was updated. This is thus the same issue as #1667. For that ticket, I manually applied a BP core patch to our installation. Since that time, the manual patch was overwritten by a BuddyPress upgrade (1.5.6; see https://github.com/castiron/cac/commit/ea56f61b8a86666ddcad59816563e5122361cb0e#wp-content/plugins/buddypress/bp-blogs/bp-blogs-functions.php).

The fix described in the BuddyPress ticket will be included in BP 1.6 and thus CAC 1.4; see #1959. In the meantime, I'll reapply the patch to the Commons: https://github.com/castiron/cac/commit/e95c4ace30b88b6acdc9ce04dbcf757c9421e759

#6 Updated by Matt Gold about 9 years ago

Nice catch, Sarah -- thank you. And thank you for the fix, Boone.

#7 Updated by Sarah Morgano about 9 years ago

Thanks, Boone.

Also available in: Atom PDF