Project

General

Profile

Actions

Bug #19966

closed

Slow Load Time on Site

Added by Laurie Hurson 2 months ago. Updated 5 days ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
-
Start date:
2024-03-13
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Hi All,

A user is developing a robust program website for a GC department. Right now it is on a dev domain and he plans to clone the site into the final domain soon. But first he is hoping to resolve the slow load times he is noticing on the site:

https://lmistest.commons.gc.cuny.edu/

-
From the User:

I am just getting really slow load times, and a lot of times, images don’t load. I was worried that I had clogged the site with too many images or something...

I have a lot of images currently uploaded to the site, especially a few big splash images, which I will ultimately delete, as I was just using these for drafts. However, we will be writing about 40 descriptions of projects we have worked on, and each one will have at least one (smaller) image, so I worry about the site slowing down even more?

I also worry it has to do with how many changes I made to the underlying theme (I’m currently using “Raft”)? I would really like to switch the theme to just a Wordpress Twenty Twenty-Four theme, but I spent a lot of time tweaking margins and padding etc. to make things look how I wanted them, so I don’t want to start from scratch… That said, if it’s an issue with the images, maybe the theme doesn’t have much to do with it?

-

I ran the site through a free (questionably accurate) load time checker and it did report the site was very slow. Can you all confirm slow load time and help diagnose what might be causing this?

Thanks!

Actions #1

Updated by Laurie Hurson 2 months ago

An update on Images from the user

when I went to the cloned site (which I just added you as an admin to), the images were not loading again. However, after I navigated around the site for a bit, they started loading. Yesterday though, it took quite a while for a few of them to load.

I was able to re-create the bug by accessing the original site (lmistest) through incognito mode (which I assume doesn’t access cookies and things). The images eventually loaded, but I think the issue might happen when I access the site for the first time, or the first time in a while – which could be an issue for new folks we are trying to show the site etc.

This seems related to #19400 but Jetpack is no longer activated on the site

Actions #2

Updated by Boone Gorges 2 months ago

  • Status changed from New to Reporter Feedback

I'm not able to reproduce any real slowness. The site seems OK to me.

I noticed that the site has a restrictive permissions setting. This means that all requests for images and other user-uploaded assets are routed through the WordPress application, which then checks to see whether the current user has the permission to view the image. On a page with many images, this means that WordPress can be loaded many times, which can potentially cause performance issues. It's also a problem that goes away once the site has been made public, at which point the images are served directly from Apache, which is far, far faster.

Assuming that the LMIS site is eventually going to be public, perhaps the admin of the test site could, at least temporarily, switch the privacy setting to fully-open (Dashboard > Settings > Reading). If this fixes the performance issue, then you'll know that the underlying problem will go away once the site is launched.

Actions #3

Updated by Laurie Hurson 2 months ago

Thank you for this feedback, Boone. I was not aware that a site can be slowed down based on the site visibility settings. I will let the user know and hopefully changing the site to public will help with load time.

thanks!

Actions #4

Updated by Boone Gorges 5 days ago

  • Status changed from Reporter Feedback to Resolved

Tentatively closing this one, but please reopen if more issues come up.

Actions

Also available in: Atom PDF