Project

General

Profile

Actions

Bug #20062

closed

Quick Edit Feature Resets Post Author to First User in List

Added by Zachary Muhlbauer about 2 months ago. Updated 26 days ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Blogs (BuddyPress)
Target version:
Start date:
2024-03-26
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

When I use the Quick Edit option to make changes to an existing post, the author of the post automatically resets to the first individual listed in the site's user list, regardless of who the original author was.

I replicated the issue in Firefox and Safari as well as across multiple themes. I also spoke with another instructor and confirmed that the Quick Edit option resets post authorship for them, too.

It's a nasty little bug if only because determining the original author of certain posts can be tricky and time-consuming when there isn't an available edit history for the post.


Files

quick-edit-bug.mov (1.78 MB) quick-edit-bug.mov Zachary Muhlbauer, 2024-03-26 07:02 PM

Related issues

Related to CUNY Academic Commons - Bug #19166: "Author" option is missing in Quick EditResolvedRaymond Hoh2023-10-31

Actions
Actions #1

Updated by Raymond Hoh about 2 months ago

  • Related to Bug #19166: "Author" option is missing in Quick Edit added
Actions #2

Updated by Raymond Hoh about 2 months ago

  • Assignee set to Raymond Hoh
  • Target version set to 2.3.6

Thanks for finding this bug, Zach. The Quick Edit Author feature was brought back in #19166, but it looks like I forgot to keep the author of the post as selected in the dropdown select menu.

Will look into this.

Actions #3

Updated by Raymond Hoh about 2 months ago

  • Status changed from New to Staged for Production Release

I've added a fix for this in https://github.com/cuny-academic-commons/cac/commit/3d4baea893d245aa16e8d709c6c49822dcde0089 .

This is scheduled to be deployed in two weeks, but if we need to deploy to production sooner due to heavy usage, let me know.

Actions #4

Updated by Zachary Muhlbauer about 2 months ago

Thanks so much for this, Ray. I'm glad you were able to find a fix. No rush on deploying to production — next week is great.

Actions #5

Updated by Boone Gorges 26 days ago

  • Status changed from Staged for Production Release to Resolved
Actions

Also available in: Atom PDF