Project

General

Profile

Bug #2044

Comment field asks for name info when user logged in

Added by Matt Gold almost 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority name:
Normal
Category name:
WordPress (misc)
Target version:
Start date:
2012-08-13
Due date:
% Done:

100%

Estimated time:

Description

Just went to add a comment to Brian's "Muggy" round-up. Even though I'm logged in, I'm being asked to fill in name/email/url, etc. That didn't used to be the case. Is this related to a WP/BP version change?

History

#1 Updated by Boone Gorges almost 10 years ago

  • Target version changed from 1.4.2 to 1.4.3

#2 Updated by Matt Gold almost 10 years ago

  • Target version changed from 1.4.3 to 1.4.7

#3 Updated by Boone Gorges over 9 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio

This is probably a theme issue. Matt, can you please share a link to the post in question?

#4 Updated by Dominic Giglio over 9 years ago

Yes, Matt, could you please provide a link as Boone requested? I know I've seen Brian's weekly roundups in the past but can't seem to find the site he posts them on. Thanks.

#5 Updated by Matt Gold over 9 years ago

#6 Updated by Dominic Giglio over 9 years ago

I agree with Boone, this appears to be a theme related issue.

The Footenotes (great name by the way) blog is running the Simplex theme. The comments template file doesn't do a whole lot when it comes to the comments section. It basically makes a call to WP's internal comment_form() function. Contrast this with the Ground Control blog, which uses the Spectrum theme from WooThemes; that theme defines a few related files and functions to customize the way comments and the comment form are displayed, like making decisions about who's logged in or not.

I don't think I'd categorize this as an issue per se. This is more along the lines of a lack of functionality on the part of the theme. However, I'm not marking this as resolved just yet.

Boone, let me know if you agree. I may be missing something in the plain vanilla wp comment form function. Maybe there really is a deeper underlying issue here?

Matt, is the requirement to enter user info when commenting on Footenotes a problem? Maybe we should have Brian look at alternate themes (if Boone doesn't disagree with my assessment that is)?

#7 Updated by Boone Gorges over 9 years ago

Thanks for the explanation, Dom. My understanding of the comment_form() function is that it should be context-specific for logged-in users. Would you mind looking a little deeper to see if I'm off base here? wp-includes/comment-template.php, starting around 1550.

#8 Updated by Dominic Giglio over 9 years ago

OK, first of all, Boone, you were absolutely correct. WP 3.0 introduced the comment_form() function which standardizes the display and control/customization of a site's comment form. It adds a slew of actions and filters that can be used to control a comment form. So the issue is not in WP's commenting subsystem.

I don't know how I got it into my head that the Footenotes blog was using the Simplex theme, but it's not. It's using Manifest. I went through theme after theme, the Codex, and countless web searches to find a solution to this. On the bright side, I learned more than I wanted to know about WP commenting! :-)

Here's the problem. The Manifest theme author never updated the commenting to support 3.0+ features. It's comments.php template still hard-codes a comment form on posts. Therefore, the status of logged in users IS NOT used when displaying the form. The only solution to this issue would be to have the author update the theme or for Brian to pick a new theme.

Here's the template in question: https://github.com/castiron/cac/blob/master/wp-content/themes/manifest/comments.php

The pre-3.0 <form> code starts on line 70.

Matt, I'm sorry but I spent way more time on this issue than I probably should have. When I come across a situation where I can't figure something out, I am unable to concentrate on anything else until I've resolved it.

I'm leaving this issue open for now, since 1.4.7 isn't slated for release until Thurs. Let me know how you'd like me to proceed. I feel like this can be marked as resolved or even rejected as this is not a bug in The Commons but a failing of a third party theme.

#9 Updated by Matt Gold over 9 years ago

Matt, I'm sorry but I spent way more time on this issue than I probably should have. When I come across a situation where I can't figure something out, I am unable to concentrate on anything else until I've resolved it.

I know it's a process and that you learn lots of things along the way that increase your WP knowledge and may help with future tickets. And that tenacity is what makes you a good programmer. Thanks for your work on this.

#10 Updated by Boone Gorges over 9 years ago

Thanks for your research, Dom.

I don't want us to be in the business of bringing obsolete themes up to date. So please don't go refactoring comments.php in that theme. However, it does look like the Manifest team is still being maintained, in this case by the (excellent) wordpress.com theme team: https://wpcom-themes.svn.automattic.com/manifest/ Dom, could I ask you to do the following: On your local, set up a simple site using our existing Manifest theme. Then replace our files with an svn checkout of the wpcom-themes version. Check your local test site to make sure that there are no major changes in the way the theme looks. In short, make sure that the wpcom-themes version is an update, rather than a total fork, of the original Manifest.

If the theme looks similar enough, let's just replace our outdated version and call it a fix. Otherwise, I'll mark this ticket as Rejected and we can revisit when we do a more general theme review.

#11 Updated by Dominic Giglio over 9 years ago

Boone,

I did as you asked and don't see any major differences. I kept switching back and forth between activating our repo's version and the svn checkout and they look almost identical. There is only one issue I want to get an answer to: The comment form (which is why we're doing this) looks a little "broken?" Broken isn't really the right word, but I'm having trouble coming up with another (better) adjective. I've attached a screen shot of what the comment form looks like when the svn checkout of Manifest is active.

Let me know what you think. I think it's just a small styling issue. I don't mind tweaking it if it means Brian will have an updated version for Footenotes.

#12 Updated by Dominic Giglio over 9 years ago

Here's a another screenshot of the comment form when you're logged out.

#13 Updated by Boone Gorges over 9 years ago

Hi Dom. I think the comment form looks fine. Don't spend any time fixing it (it'd just get overwritten in future upgrades). Go ahead and commit the swapped out version.

#14 Updated by Dominic Giglio over 9 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Updated manifest theme has been uploaded.

Commit: https://github.com/castiron/cac/commit/81346db9f039b7a3efaef7e1c690e928054911eb

I've also added a note to ACTION_REQUIRED to remind Brian to double check Footenotes after the 1.4.7 release.

#15 Updated by Boone Gorges over 9 years ago

Hi Brian - Read the above thread only if you want :) Long story short, the theme you use on Footenotes was waaay out of date. In 1.4.7 we brought it up to date, but it's possible that you'll see some small changes. If you see anything that needs to be fixed, please don't hesitate to open a ticket.

Also available in: Atom PDF