Project

General

Profile

Bug #2121

Email notification of forum post omits hyperlinked word

Added by Matt Gold almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-09-12
Due date:
% Done:

0%

Estimated time:

Description

In the email notification I received of this forum post, the word "here" -- hyperlinked in the post -- did not appear. Please see screenshot.

History

#1 Updated by Dominic Giglio almost 10 years ago

Boone,

The Group Email Subscription (GES) plugin is also responsible for sending forum emails, correct?

#2 Updated by Boone Gorges almost 10 years ago

Correct, Dom.

FYI (and related to your question in #1997), GES does indeed strip tags. The function cac_strip_email_anchors() in bp-custom.php (around line 37) is intended to preempt this stripping, transforming links into plaintext like this:

   <a href="http://foo.com">Bar</a>

becomes

   Bar [http://foo.com]

However, it looks like the filter that this function attempts to hook, bp_gfs_email_content, does not exist anywhere in the codebase :) It must have been removed at some point, maybe when we switched from our old email notification plugin to the new one. So it means that this function is doing nothing. That is to say, it's not causing the problem, but getting the function to work again would be a way of skirting whatever is causing the root problem of this ticket.

It looks like, in order to get it working again, I'm going to have to change the way the GES plugin works a little bit. So don't worry about this ticket for the time being - I'll have to futz with it :)

#3 Updated by Boone Gorges almost 10 years ago

  • Status changed from Assigned to Resolved

I've reimplemented the link translator in https://github.com/castiron/cac/commit/8da0ea650596226df45d8ba90803482affb7c38e This should fix the problem. If you note the problem arising after the 1.4.6 release, please reopen this ticket with steps to reproduce.

Also available in: Atom PDF