Project

General

Profile

Feature #2147

Plugin Request Facebook (official) or Similar

Added by Keith Miyake almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority name:
Low
Category name:
WordPress (misc)
Target version:
Start date:
2012-09-26
Due date:
% Done:

0%

Estimated time:

Description

The official facebook plugin is sort of a beast and has pretty bad reviews on wp.org, but it's one of only a handful of plugins that handles auto-posting on facebook. As far as I can tell, all of the plugins require users to create a facebook application since facebook started using oauth. Not so different from the twitter tools plugin already installed in CAC.

Here's the official Facebook plugin: http://wordpress.org/extend/plugins/facebook/

And here are the other options that I found:
-haven't fully tested but also works with twitter and other social sites: http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/
-couldn't authenticate but looks really simple: http://wordpress.org/extend/plugins/status-updater/
-looked like a pain to configure: http://wordpress.org/extend/plugins/facebook-awd/

History

#1 Updated by Matt Gold almost 9 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to 1.4.6
  • Severity set to Low impact

#2 Updated by Boone Gorges almost 9 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio

Dom, could you look at these plugins and make a judgment call? Thanks.

#3 Updated by Dominic Giglio almost 9 years ago

First af all, not only does the official Facebook plugin have some bad reviews, it's page on the plugin repo says that it doesn't work with 3.4.2. So I don't suggest we go with that solution.

Out of the other three, my gut says we go with the second: http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

On a site as large as the commons, we want to try and provide plugins that benefit the maximum amount of users as possible. I assume that if one person wants to auto publish to Facebook, that user (as well as others) will also want to publish to other social sites. The second plugin will allow this in a single plugin.

However, I looked through the code, and I have to say, I'm a little put off by the lack of organization and adherence to WP coding standards. This doesn't mean that the plugin won't work - or work well - I just wanted to bring it up. Although I've never tried to write up a solution that integrates with so many OAuth providers, so I may not be the best critic in this instance. :-)

I'm wondering if we should add the Social Networks Auto Poster and then punt this to 1.4.7 or 1.4.8 so we can test it out on cdev. Testing a plugin that integrates with so many external APIs is a little difficult and requires more attention than just me looking at the source. Being able to test this with our (The Commons) Twitter account and Facebook page will give us a much better idea of whether or not it's going to work for the rest of our users.

#4 Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.4.6 to 1.4.7

On a site as large as the commons, we want to try and provide plugins that benefit the maximum amount of users as possible.

I agree with this in theory. The problem is that we already have a bunch of plugins that do similar things for Twitter (and possibly other sites), and so introducing more options for those people just means more things that we have to support down the road.

Anyway, I do agree that your suggested choice is probably the best of the options, just based on ratings and a quick glance at the support forums for each. Let's go with your suggestion of punting this so we can do further testing on cdev. (If it's going to take ages to test each social network, just start with Twitter and Facebook, as they'll be the most popular, and we can worry about the others down the line.)

#5 Updated by Dominic Giglio almost 9 years ago

we already have a bunch of plugins that do similar things for Twitter (and possibly other sites)

Do you mean to say that we have existing plugins already installed that will auto post to Facebook and Twitter? I believe that's what Keith is really after here. Facebook and Twitter integration into a page is one thing. It's much easier to display social content on a site than it is to send your content out to one of your social networks. I think if we have plugins that will auto post content Keith and I should be looking at those before we add a new one.

#6 Updated by Boone Gorges almost 9 years ago

We do, in fact, have several plugins that allow posting content to Twitter. I don't know of an installed plugin that does the same for FB.

#7 Updated by Dominic Giglio almost 9 years ago

Boone,

I've created a new topic branch called facebook-plugin where I've added the Social Networks Auto Poster plugin and pushed it to the repo. Is cdev available to start testing this plugin?

#8 Updated by Boone Gorges almost 9 years ago

Is cdev available to start testing this plugin?

Yep, all yours.

#9 Updated by Dominic Giglio almost 9 years ago

  • Target version changed from 1.4.7 to 1.4.8

#10 Updated by Dominic Giglio almost 9 years ago

  • Target version changed from 1.4.8 to 1.4.9

#11 Updated by Dominic Giglio almost 9 years ago

  • Target version changed from 1.4.9 to 1.4.10

#12 Updated by Keith Miyake almost 9 years ago

The recent CAC update of the Twitter Tools plugin to version 3+ now requires the installation of the "Social" plugin (http://wordpress.org/extend/plugins/social/) for it to continue working. The Social plugin appears to have the functionality requested in this ticket. I haven't tried it out on my test site, but that might be a viable solution without overlapping existing functionality.

Since Dominic has already begun testing the SNAP plugin, I have no objections to using that instead of Twitter Tools+Social if it seems like that would be a better solution, but this is potentially an alternative solution.

#13 Updated by Dominic Giglio almost 9 years ago

Keith,

I've added Social so Twitter Tools will begin working again on Sunday night after the 1.4.10 release. I haven't been able to dedicate as much time as I would have liked to testing SNAP (as evidenced by the number of times I've bumped this issue from milestone to milestone). Because Twitter Tools now relies on Social and Social appears to provide the functionality requested in this issue, I think we should give it a chance and see if it can provide the features you're looking for. It wouldn't make sense to add Social because it's needed by another plugin and then add SNAP to get Facebook posting when we could get it from Social. Two birds...one stone.

If you wouldn't mind, could you test Social for me this coming week when you have some time and let me know if it does what you need? If it doesn't, I'll pick SNAP testing back up and we'll add it if you need it.

Boone,

We currently have 26 sites using Twitter Tools. Do we need to go to each of those sites to enable Social after the 1.4.10 release? If so, I don't mind taking care of that, I just want to put a reminder on ACTION_REQUIRED so we don't forget. I'm wondering if the simple existence of Social will satisfy Twitter Tools or if the actual activation is necessary. I wouldn't want to activate another plugin on those sites if we don't need to.

#14 Updated by Keith Miyake almost 9 years ago

thanks, boone. I completely agree with your assessment. I'll give it a go this week and report back.

#15 Updated by Dominic Giglio almost 9 years ago

Thanks, and it's Dom by the way, but no worries. :-)

If I'm gonna be mistaken for someone, I'd like it to be Boone! LOL

#16 Updated by Keith Miyake almost 9 years ago

sorry Dom! I'm on my phone and the email chain had Boones name in there somewhere so I didn't look twice.

also, I do believe the social plugin will need to be activated on all of the sites because I believe that twitter tools is now dependent on social being active before it will even load.

#17 Updated by Dominic Giglio almost 9 years ago

I was thinking the same thing about activating Social, if it's not active Twitter Tools has no was of knowing it's there.

Boone or I will make sure that happens after the release.

#18 Updated by Dominic Giglio almost 9 years ago

  • Target version changed from 1.4.10 to 1.4.11

#19 Updated by Dominic Giglio almost 9 years ago

Keith,

We'll be releasing 1.4.12 later today; have you had a chance to check out Social? Does it provide the features you originally requested in this ticket?

#20 Updated by Keith Miyake almost 9 years ago

I just used Social for the first time today and it seems to work for our needs. Thanks!

#21 Updated by Dominic Giglio almost 9 years ago

  • Status changed from Assigned to Resolved

Glad to hear it. Please let us know if you need anything further.

Also available in: Atom PDF