Project

General

Profile

Bug #215

Inaccurate dates on group page`

Added by Matt Gold about 12 years ago. Updated about 12 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2010-05-06
Due date:
% Done:

0%

Estimated time:

Description

A Commons member noticed that she is listed as having joined a group 40 years ago - http://commons.gc.cuny.edu/groups/qc-technology-fee-group/members/

Not as high a priority as other things on our list, but something to get to when we can.

History

#1 Updated by Matt Gold about 12 years ago

Another time/date related problem. Michael O-M reports:

"Just send a 'private message' in the system and as soon as it was sent it said "sent 4 hours ago" although I had sent it at 11:15 am, which is like now.

So is there a clock set wrong somewhere in there or?"

#2 Updated by Boone Gorges about 12 years ago

Pretty sure these are BP core bugs.

I tracked down Michael's bug and fixed it in the core. Well, not really "fixed" but at least made the problem go away with a manual time adjustment.

#3 Updated by Boone Gorges about 12 years ago

  • Status changed from Assigned to Resolved

Fixed. The problem is that, with a fairly large number of groups, the date_joined date for the group creator was being set to 0, or the unix epoch time. Not sure whether this is a BP bug or a holdover from an older version of BP. In any case, I've written a filter that replaces the date_joined with the creation date of the group when the date_joined = the unix epoch

Also available in: Atom PDF