Project

General

Profile

Bug #2193

login

Added by erin glass almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2012-10-15
Due date:
% Done:

0%

Estimated time:

Description

Login to the Commons always takes two tries. Hardly noticed it myself -- but saw it happen during Steve Brier's ITP class as well. Apologies if this is already reported.

export.pdf (14 KB) export.pdf Matt Gold, 2012-10-15 03:32 PM

Related issues

Is duplicate of CUNY Academic Commons - Feature #228: Warn users who have cookies turned offRejected2010-05-08

History

#1 Updated by Matt Gold almost 9 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Dominic Giglio
  • Severity set to Normal

Hi Erin,

Can you give us some information about the computer/browser environments on which you're experiencing this? Please visit http://supportdetails.com/ and send us what you see there as soon as you experience it.

My guess (we'll see whether our devs agree) is that this is a caching issue -- that you are actually logged in after the first try, but that your browser is showing you a cached version of the page. The next time this happens, you might try a hard refresh to see what happens.

#2 Updated by erin glass almost 9 years ago

Matt -- I sent your email address info from supportdetails.com. Please let me know if there is a better email to send to.

I had thought it might be just a personal glitch. However, when Steve Brier experienced the same issue during class, everyone said the same thing happened to them. He said he would bring it your attention, but I thought I would too in case he forgot.

#3 Updated by Matt Gold almost 9 years ago

details attached

#4 Updated by Boone Gorges almost 9 years ago

Pretty sure this is, again, due to http://redmine.gc.cuny.edu/issues/228. Dom, start taking a look there.

#5 Updated by Dominic Giglio almost 9 years ago

  • Target version set to 1.4.8

Will get on it as soon as I can.

#6 Updated by Steve Brier almost 9 years ago

I do have the same "double login" problem when I use GC classroom computers to login to my course site. Not sure if that's a cache issue or something else. Glad Erin reported it.

#7 Updated by Matt Gold almost 9 years ago

Hi Steve -- the ticket Boone linked to suggests that it is a problem that occurs on computers that disallow cookies: http://redmine.gc.cuny.edu/issues/228

As that ticket notes, we're working on a better way to inform users about this problem when it occurs. . . .

#8 Updated by Dominic Giglio almost 9 years ago

  • Target version changed from 1.4.8 to 1.4.9

#9 Updated by Boone Gorges almost 9 years ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Dominic Giglio to Boone Gorges

I've removed the login cookie check that was causing the problem. See #228 for more details.

https://github.com/castiron/cac/commit/141cdd8e1cb9c77f8563e62cc55d215b3b317035

Also available in: Atom PDF