Project

General

Profile

Bug #2247

Subdomain site login/nav bar issue

Added by Matt Gold almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority name:
Low
Category name:
WordPress (misc)
Target version:
Start date:
2012-11-12
Due date:
% Done:

0%

Estimated time:

Description

I visited the Commons and logged in. Nav bar shows me in a logged-in state. Then I visit the PCP site - http://pcp.gc.cuny.edu/ - and I see two weird things:

-- The top nav bar doesn't show that I'm logged in
-- The nav bar itself is styled a bit differently than our regular nav bar.

Thoughts?


Related issues

Is duplicate of CUNY Academic Commons - Feature #1508: Share login cookies across mapped domainsAssigned2012-01-05

History

#1 Updated by Boone Gorges almost 9 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio
  • Target version set to 1.4.12

Your login issue is a duplicate of http://redmine.gc.cuny.edu/issues/1508

Dom, please have a look at the CSS issue. Our stylesheet is clearly being loaded, but perhaps being overridden by something.

#2 Updated by Dominic Giglio almost 9 years ago

While researching this issue I noticed some commonalities between the sites affected.

1.) While inspecting the assets being loaded by each I noticed a javascript file named admin-bar-rest.js. This file comes from the notifications portion of the JetPack plugin. It seems to be inserting itself into the admin bar in order to enable notifications from wp.com. Right now I believe this may be the main culprit.

2.) All sites affected by the issue are running the Atahualpa theme.

3.) All sites affected by the issue are running JetPack.

4.) All sites are (I think) domain mapped to gc.cuny.edu. (no commons subdomain)

There are six sites that fall into the above conditions with one difference:

These two are not domain mapped and therefore are not experiencing the issue:
Gslis720 Digital
Keith K Miyake at the CUNY Academic Commons

These sites are domain mapped and therefore are experiencing the issue:
Committee on Globalization and Social Change
The Center for Place, Culture and Politics
The Committee for Interdisciplinary Science Studies
The Committee for the Study of Religion

So I think what we're seeing here is a conflict between Atahualpa, JetPack and domain mapping. I'm not sure yet exactly where the conflict is occurring but I wanted to update here incase one of you sees the problem before I can.

Boone, you mentioned that there have been some customizations to Atahualpa, could they be introducing this issue?

I've added Ray as a watcher here because he's a watcher on the duplicated issue #1508.

#3 Updated by Dominic Giglio almost 9 years ago

  • Target version changed from 1.4.12 to 1.4.13

#4 Updated by Boone Gorges almost 9 years ago

  • Status changed from Assigned to Resolved

The additional menu bar item from the screenshot (the speech bubble) is being inserted by Jetpack. Not much we can do about that.

The darker color of the link text ("Log In", etc) is caused by Atahualpa.

The extra border is being caused by the additional button inserted by Jetpack.

In https://github.com/castiron/cac/commit/3d5a4d348450a7a7803389c005eb64aeaef43e41, I add some styles that will override these issues.

#5 Updated by Matt Gold almost 9 years ago

Thanks, Boone.

Also available in: Atom PDF