Project

General

Profile

Bug #2543

Minor issues with Fellowships website

Added by erin glass over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority name:
Normal
Category name:
WordPress (misc)
Target version:
Start date:
2013-04-19
Due date:
% Done:

0%

Estimated time:

Description

Hi Dom,

Hoping you can help me with two minor issues on the fellowship & funding website.

1) I forgot to specify that the GC logo should link to the Graduate Center homepage: (http://www.gc.cuny.edu/Home). Is it possible to add this for the next update? Let me know if there is anything I can do to help.

2) From Chris Caruso: On Louise's work computer (Windows 7, Internet Explorer 9), the top menu bar doesn't show up at all. When she uses Firefox on the same machine, the menu bar is there and everything looks fine. Also looks fine on my Mac. IE is so irritating. Can you see if there is a potential fix for this?

Thanks!

Erin

IEsite.PNG (1.15 MB) IEsite.PNG erin glass, 2013-05-02 03:12 PM
featured-students.png (607 KB) featured-students.png Dominic Giglio, 2013-07-01 12:57 PM
homepage.png (644 KB) homepage.png Dominic Giglio, 2013-07-01 12:57 PM
single-student.png (590 KB) single-student.png Dominic Giglio, 2013-07-01 12:57 PM

History

#1 Updated by Dominic Giglio over 6 years ago

  • Target version set to 1.4.26

#1) I've changed the logo from just an <img> tag to a link with the image as it's content. This update will go live with tomorrow's 1.4.25 release.

Commit: https://github.com/castiron/cac/commit/1a87fabe41a88b61ec452e6e5edd87f4761587fa

#2) Internet Explorer is the bane of every web developer's existence. Can you get me a screen shot? It's very difficult for me to debug a problem with IE (version whatever) because I don't run windows nor do I own a machine on which I could. It would also help if you could ask other windows/IE users to visit the site to see if we can reproduce this error. If we can identify a difference or the similarities between machines that experience the error and those that don't it might help us track down the cause.

I've moved this issue to target version 1.4.26 to give us some time to try and track down the IE error.

Also, in the future, if you have multiple questions that are not related to each another, could you please open separate tickets? It helps to keep the issues cleaner and simpler. It also enables us to look back over closed issues with a little more ease and less confusion about what each ticket was regarding and how it was solved. Thanks.

#2 Updated by Dominic Giglio over 6 years ago

  • Target version changed from 1.4.26 to 1.4.27

#3 Updated by erin glass over 6 years ago

Hi Dom,

Attached is a screen shot of the site misbehaving on IE. Not sure if this will be an easy fix. My feeling is that no one uses IE, but of course, it would be preferable to have the site work across all browsers. What's your opinion?

Best,

Erin

#4 Updated by Dominic Giglio over 6 years ago

As web developers and designers it should always be our goal to make a site look as consistent as possible across as many browsers as we can. IE has always made this difficult. It is the bane of our existence. I always try to move anyone I see running IE to either Firefox or Chrome. :-)

I'm a little confused by this issue. I do not see the WP Adminbar when I visit the site. Additionally, there is an entry in the custom CSS that I assume is the cause:

#wpadminbar {
  display:none
}

What we need to decide here is whether or not the Adminbar is "supposed" to be displayed. What I really don't understand is why you see it on your computer. With that entry in the custom CSS it shouldn't be showing up in your browser either.

Right now, what appears to be happening (as far as I can tell), is that some of the custom CSS is making the site look different in different browsers. Looking at your latest screenshot and comparing it to what I see in Chrome, makes apparent some glaring inconsistencies. The background (grey-ish pattern) is clearly visible "behind" the sidebar content and around the main site content. That's why "Opportunities" looks like it's starting to be covered by the white header. Also, the entire black navigation area is just not there. As web developers we are supposed to look at our sites in as many browsers as we can when editing our CSS; this is the reason why. I freely admit that I fail to do this all too often.

My suggestion would be to cut all the custom CSS out from the admin and paste it into a text file to save it. I would then look at the site in IE and Chrome to see how it looks. I would then starting adding back the CSS one rule at a time (this is the basic definition of troubleshooting), checking in both IE and Chrome, and see where the divergence first occurs. If nothing else, it will teach you a heck of a lot about cross browser CSS styling. Most developers/designers are paid not because they know how to write CSS, but because they know how to wright cross browser CSS. :-)

#5 Updated by erin glass over 6 years ago

This is really helpful, Dom. Thanks much. I had no idea it might be a CSS issue. I'll will start playing around and let you know what I find!

#6 Updated by Boone Gorges over 6 years ago

  • Target version changed from 1.4.27 to 1.4.28

#7 Updated by Dominic Giglio over 6 years ago

  • Target version changed from 1.4.28 to 1.4.29

#8 Updated by Boone Gorges over 6 years ago

  • Target version changed from 1.4.29 to 1.4.30

#9 Updated by Dominic Giglio over 6 years ago

  • Target version changed from 1.4.30 to 1.4.31

Erin,

Have you had a chance to look into these cross browser CSS issues? I don't want you to think I'm rushing you, cross browser testing takes time and I'm only curious if you've had a chance to work further on this issue.

We may want to move this to the "Not Tracked" target, it doesn't make much sense to keep bumping the target three times a month for each release. Let me know what you think. We can leave it in Not Tracked until you've had a chance to investigate further.

#10 Updated by erin glass over 6 years ago

  • Target version changed from 1.4.31 to Not tracked

Hi Dom,

Thanks for the reminder. I still haven't had a chance to work on this as I'm sorting out other changes Louise requested that I make. I'll change this ticket now to the "not tracked" target.

Best,

Erin

#11 Updated by Dominic Giglio over 6 years ago

Thanks.

Maybe you and I can set aside some time over our break to have a call about some of the challenges to cross-browser compatibility. I'm no expert but I might have some tidbits of knowledge that could help. :-)

#12 Updated by Matt Gold over 6 years ago

  • Target version changed from Not tracked to 1.4.31

Hi Erin -- if you don't mind, I think we should keep this tied to an issue to keep it in view.

#13 Updated by Dominic Giglio over 6 years ago

sorry Matt, that's on me.

I suggested we move it out of a target so Boone and I didn't need to keep punting it every 11 days. I thought we could move it back into a target once Erin has had a chance to investigate deeper.

#14 Updated by Matt Gold over 6 years ago

No worries, Dom.

#15 Updated by erin glass about 6 years ago

Hi Dom,

Would it be possible (for the next update) to remove the php command in the Luna child theme that puts the date stamp on the blog posts? Can definitely fool around with this on my own & fwd you the file but if it's no trouble to you, would probably be much speedier for you to just remove the code before updating. Let me know!

Thanks!

Erin

#16 Updated by Dominic Giglio about 6 years ago

Ya, this should be no problem at all.

Just so I'm clear, you want the date removed from the line just below the featured image? Like on Micki Kaufman's page here:

http://fellowships.commons.gc.cuny.edu/micki-kaufman/

Would you like that whole line removed or just the date?

Also, those dates appear on the homepage as well, would you like those removed too?

#17 Updated by Matt Gold about 6 years ago

Hi Erin --

I'm going to step in here and say that you should give this a shot yourself before we have Dom take it on. Please give yourself 2-3 hours to see if you can figure this out, and then, if you can't, Dom can help out.

I make this request because I think that this is a really good example of a way that you can start getting under the hood of WordPress and learning a bit more about PHP. Please give it a shot and let us know how it goes.

Also, two other things:

-- let's try to keep to a one-task-per-ticket rule. New tasks/requests should go into new tickets
-- If you get started on this and run into a problem, consider posting something in our Commons group for the Fellows or in the group we have with Dom

Many thanks.

Best,

Matt

#18 Updated by Matt Gold about 6 years ago

Okay, Dom -- can you please go ahead and make this fix for Erin? The project is time-sensitive so it's best, in this case, just to move forward as quickly as we can. Many thanks.

#19 Updated by Dominic Giglio about 6 years ago

No worries Matt, I'll get the changes in and I'll even try and write up a tutorial for the Sandbox blog so everyone can learn how it was done.

#20 Updated by Matt Gold about 6 years ago

Awesome - thanks, Dom.

#21 Updated by erin glass about 6 years ago

Thanks, all! Also, Dom, you are correct -- I'm hoping to get the time stamp removed from both the individual profile page (like Micki Kaufmann's) as well as from the homepage or blog page (http://fellowships.commons.gc.cuny.edu/featured-students/). I think it's ok to leave the tags in this line -- but I'm glad you brought that up as I'm not sure what the rest of the group will think. Do you think it would be good to have a little clarifying phrase before the tags, such as "Posted in: ..." ?

#22 Updated by Dominic Giglio about 6 years ago

I think there should be a "clarifying phrase." Just so there aren't random words under the picture without a context.

I'm going to remove the whole phrase "18 FEBRUARY ON FELLOWSHIPS & FUNDING" because the "on fellowships and funding" is redundant. I'll play around with some phrasing like "posted in..." But if you could ask around for feedback from the group that would be cool. Maybe start a new forum post on our group asking for comments and feedback? By the time we get a consensus I should have the edits complete and I can paste in whatever the final phrasing is so we can get the changes into the 1.4.31 release (this coming Monday).

#23 Updated by Matt Gold about 6 years ago

We might consider removing all category listings from that page -- just have the student name and the beginning of the bio paragraph. The page would be cleaner as a result, and I suppose the only thing we'd miss is the extra info about all the different categories we have . . . but those categories are repeated on the right, so there's really no need to have them in the main part of the page, too.

#24 Updated by Dominic Giglio about 6 years ago

I agree that the whole line of meta-data should be removed from the homepage and even the featured students page.

What I'm really wondering about is this: what is the context of these tags? Are they interests or areas of study for these students? If that's the case, then we should just "reclassify" this taxonomy. Instead of saying "Tagged: blah, blah, blah" or "Posted in: such and such" we can output them as an unordered (or ordered) list of interests or fields of study; output them right between the image and full bio. That way visitors can browse right to the pages that list other students with similar interests and fields of study. But only display them on the single student page (not the homepage or /featured-students/ page). Am I making sense?

#25 Updated by Matt Gold about 6 years ago

Hi Dom -- my sense is that they are already outputted as a list in the right sidebar under "more student stories," which lists various categories of fellowships.

#26 Updated by erin glass about 6 years ago

Hi Dom, There are three types of categories. One specifies the program(s), one specifies the type(s) of fellowship(s) and one specifies whether the profile has a testimony or not. I think it makes sense to remove them from the homepage and blog, but perhaps keep them for the individual profile pages. If we're able to differentiate between categories (they are ordered in a hierarchy in the dashboard) perhaps we could have the language read: "Program: (categories)" and "Fellowship: (categories)" and then just have the testimony category not show up? The reason the testimony category is useful is because one of the homepage links goes directly to a set of profiles that have first-person testimonials in them, instead of just bios. If this is too complicated, however, then maybe we just delete them all together?

Let me know what you think.

Best,

Erin

#27 Updated by Dominic Giglio about 6 years ago

Take a look at what I put together for the GCEnglish (English Student Association) site when viewing an individual student profile:

http://gcenglish.commons.gc.cuny.edu/profile/andelman-michelle/

When browsing all the students on that site (or it's homepage) you only see a small part of the bio. But when you're viewing an individual student's profile there is additional information displayed next to their profile picture. I'm thinking about a similar solution for this issue. Only the individual featured student page will display the additional tags in question. I'm thinking about just listing them to the right of the picture and then the full bio down below.

The programs and fellowships categories should be easy-peasy for me to code into the template's layout; I'll be able to answer more specifically about the testimonials category once I get my head into the actual code.

#28 Updated by Dominic Giglio about 6 years ago

Erin,

I've removed the meta data from the homepage and the /featured-students/ page, and removed the date from the meta data on the single student pages.

This involved overriding the loop-entry.php file in our Luna child. I'll probably write my next sandbox post about this issue. Just a quick tutorial on why the theme uses a loop-*.php template file and how/where I edited that meta data content.

I think going forward, if you'd like to further customize the output of these profiles/bios, we should have a discussion on the Sandbox forum about reorganizing the categories and talk about how they're used. In your last update you said:

we could have the language read: "Program: (categories)" and "Fellowship: (categories)"

But on the site itself the categories are "Department" and "Fellowships & Funding." By renaming and reorganizing the categories we'll be able to better output their information on different pages. For example, on the homepage, the sidebar title should probably read: "Programs" not "categories" and if you look at Micki Kaufmann's post in the admin, you can see that the post is in the History category, but that category is not assigned to a parent, it's a top level category. I'm assuming this is incorrect as far as the hierarchy goes, it should probably be under "Departments?"

Once we discuss and decide on what those categories should actually look like, we can revisit crafting a more advanced single bio page. One where we can programmatically output exactly the info we want in the structure we want.

Let me know if we can close out this issue. I've already pushed up these small changes so they'll go live in tonights release. I've also attached three screenshots so you can see what I'm seeing in my local env now.

#29 Updated by Matt Gold about 6 years ago

Looking forward to hearing Erin's thoughts, but those screenshots look great to me. Thanks, Dom. BTW, there is no update tonight, since we're on a summer schedule. The next update is July 11. This is an important project, though, so if we need to go sooner, we can -- let's talk about that separately, Erin.

#30 Updated by Dominic Giglio about 6 years ago

Oh, good to know. So are we only once a month over the summer? Just the 11th?

#31 Updated by erin glass about 6 years ago

Hi Dom,

The changes look great! Thanks so much. I agree with you, if we want to make any further customizations, we should discuss naming and ordering of categories. For now, though, I think we can close the issue.

Also, on my end in the dashboard it looks as if the 'History' category is assigned the parent category "Departments." Did you change it? Am I not understanding something right?

I'll check in with the group about the July 11 update. If they are looking for something sooner, I will discuss with Matt.

Thanks again!

Erin

#32 Updated by Dominic Giglio about 6 years ago

  • Status changed from New to Resolved

You're welcome, I'm glad you're happy with the changes. I'm marking this as resolved.

I'm not sure why this is happening (yet), but you're right; the History category is properly listed as a sub-category of "Department" when I look at the list of all categories (Post->Categories in the admin). But, when I edit Micki Kaufman's post the Categories metabox (between Format and Tags) makes it look like the History category is a top level category just like Department and Fellowships & Funding are.

This will take a little investigation, and may very well magically disappear if/when we start reorganizing and renaming the taxonomies across the site. I think we should put a pin in this since nothing's broken and we may be swinging back around to it when we can focus on it a little closer.

#33 Updated by Matt Gold about 6 years ago

Thanks, Dom, for your work on this. Erin, please keep your eye on the category issue and start a new ticket if it persists. Many thanks.

Also available in: Atom PDF