Project

General

Profile

Bug #2772

Fellowship website layout bug

Added by erin glass about 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority name:
Normal
Category name:
WordPress (misc)
Target version:
Start date:
2013-09-03
Due date:
% Done:

0%

Estimated time:

Description

I'm writing because the recent Commons update seems to have dismantled the layout of the homepage of the Fellowships and Funding webpage. We were in the middle of doing final edits before launch, so hoping to resolve this issue soon. Let me know about any steps I should take.

Here's the website url: https://fellowships.commons.gc.cuny.edu/

The password is fellowships2013.

History

#1 Updated by Dominic Giglio about 8 years ago

Hey Erin!

Summer was fine, went by WAY too fast. Hope your's was great.

Just started looking at the site, it appears to be a javascript issue at first glance. The slider appears to be broken and is outputting all the images instead of hiding them and then sliding them.

It looks broken in Safari but appears to work in Chrome. What browser are you using?

#2 Updated by erin glass about 8 years ago

Agree about the speedy summer!

The site looks broken on Safari and Firefox. I don't have Chrome installed on my office computer -- but I will put in a request!

Thanks!

#3 Updated by Matt Gold about 8 years ago

please also test in IE, which is what most computers at the GC have set as default. Many thanks.

#4 Updated by Dominic Giglio about 8 years ago

OK, let me dig around and see what's going on here.

#5 Updated by Matt Gold about 8 years ago

  • Status changed from New to Assigned

#6 Updated by erin glass about 8 years ago

Hi Dom,

Sorry to check in so early, but the project manager of the site is eager to hear about when the homepage might be fixed. Let me know if you think it will be next week or later and I can send her an update.

Many, many thanks!

Erin

#7 Updated by Keith Miyake about 8 years ago

the problem is that the theme is trying to dynamically load a pretty outdated version of jquery after the main WP jquery call:
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js?ver=1.5.2"></script>

this breaks the slider and any other jquery functionality.

given the place in the header where this call is made, I have a feeling it's in the theme.

I just did a fresh install of luna on a blank site and saw the same header include so I'm almost positive that's the problem.

the easiest fix (that Dom or another admin has to do) is to just remove that line from the header.php or the static include in the theme's functions.php. Since they didn't enqueue the script I'm putting money on the header.php.

Removing the line in Chrome's Dev Tools got jquery up and working again.

#8 Updated by Dominic Giglio about 8 years ago

Keith,

Thanks for the heads up! I really appreciate it.

Erin,

It definitely will not be next week. Now that Keith has pointed out what most likely is the exact cause I should have it fixed tonight or tomorrow.

#9 Updated by Dominic Giglio about 8 years ago

Hey Erin,

Sorry, been tied up with the startup I'm working on.

I'm looking at the theme right now and Keith is almost correct. Luna is enqueueing the old jQuery file in its includes/custom/custom-functions.php file. As soon as I figure out the correct code to prevent this from being loaded in the header I will push up the fix and it will be working again after the next release (Wednesday).

I'll update again here as soon as I push up the fix.

#10 Updated by Keith Miyake about 8 years ago

Dom, if you attach the custom-functions.php file I can probably get you a quick fix. I can't access the theme files directly since it's a premium theme so maybe you can attach it on here.

#11 Updated by Dominic Giglio about 8 years ago

No need, Keith. I got it figured out. I created a function in the Fellowship's child functions.php and attached it to the wp_print_sctipts action. It effectively removes the registration of the offending jQuery version that's being loaded from Google, fixing the current issue with the slider on the homepage. I really didn't want to edit the Luna parent directly. I would have if there were no other options, but staying inside the child theme is always the best bet.

I am waiting on an answer from another issue right now, and as soon as I get that answer I'll be able to push this fix up for the release on Wed.

Thank you again for looking into this issue. Your feedback helped a lot.

#12 Updated by Dominic Giglio about 8 years ago

  • Target version set to 1.5.2

#13 Updated by Dominic Giglio about 8 years ago

The updates discussed above have been pushed to our repo, so they'll be included in today's release. I will verify the fix after the release and update here to let everyone know whether or not this issue can be closed.

#14 Updated by Boone Gorges about 8 years ago

  • Target version changed from 1.5.2 to 1.5.3

#15 Updated by erin glass about 8 years ago

Thanks so much to both of you! Site looks great in Firefox! Will check other browsers at another computer.

#16 Updated by Dominic Giglio about 8 years ago

  • Status changed from Assigned to Resolved

Glad we got it fixed and working Erin.

I've checked in Safari, Firefox and Chrome on my Mac and it looks good in all of them. If you find an error in another browser please open a new issue for that problem. I'm closing this one since it appears to be working fine.

#17 Updated by Matt Gold almost 8 years ago

Fantastic - many thanks for your work on this, Dom.

Also available in: Atom PDF