Project

General

Profile

Support #2794

redirect for research.commons.gc.cuny.edu

Added by Keith Miyake almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2013-09-14
Due date:
% Done:

0%

Estimated time:

Description

We need to add an http/htaccess redirect to the old ARC commons site that points from research.gc.cuny.edu to http://gc.cuny.edu/Degrees-Research/The-Advanced-Research-Collaborative.

In conjunction with this redirect, can we also get a file and db backup and change the "research" wpmu subdomain to something like "research-backup" so that it's still accessible for now?

This redirect needs to happen before 9/23, but not until I've gotten the OK, hopefully in the next couple of days. I'll update this thread when we're ready to go but wanted to get this started so that the transition can happen quickly.

History

#1 Updated by Keith Miyake almost 6 years ago

sorry, just noticed that I forgot to change the type of this ticket from bug to support. can an admin change that please?

#2 Updated by Keith Miyake almost 6 years ago

I just got the OK to make this happen.

So just to be clear, here's what I'm requesting:
  1. pull a file/db backup of research.commons.gc.cuny.edu
  2. remap wordpress multisite blog research.commons.gc.cuny.edu -> research-backup.commons.gc.cuny.edu
  3. htaccess rewrite research.commons.gc.cuny.edu -> http://gc.cuny.edu/Degrees-Research/The-Advanced-Research-Collaborative

#3 Updated by Matt Gold almost 6 years ago

  • Tracker changed from Bug to Support
  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

Thanks, Keith. Regarding #1, have you exported blog content from dashboard > settings > export ?

#4 Updated by Keith Miyake almost 6 years ago

Sorry, forgot to mention that I don't have admin access to the site, so I can't get in to export the db.

#5 Updated by Matt Gold almost 6 years ago

Okay -- can you ask Chris to make you an admin?

#6 Updated by Keith Miyake almost 6 years ago

DB backup is completed!

#7 Updated by Boone Gorges over 5 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version changed from Not tracked to 1.5.3

I'm assuming that "research.gc.cuny.edu" is a mistype for "research.commons.gc.cuny.edu", right?

pull a file/db backup of research.commons.gc.cuny.edu

I'll create a zip backup of all files. Keith, can you let me know how/where you want it sent? I'm assuming you already have the db backup you need.

remap wordpress multisite blog research.commons.gc.cuny.edu -> research-backup.commons.gc.cuny.edu

I can make the basic change pretty easily, but it will break many internal links, and all external links that point toward the site. That's ok, right?

Redirect implemented in https://github.com/castiron/cac/commit/f20032d5fdad9229d9aa26b5042c2a6185eba1d4. This will be part of the Commons 1.5.3 release on Saturday the 21st.

#8 Updated by Matt Gold over 5 years ago

Added Chris Caruso as a watcher

#9 Updated by Keith Miyake over 5 years ago

Thanks Boone.

You're right about the research.commons.gc.edu address.

I have the database backup already. Can you upload the zip to zippyshare or some other file hosting site? Or even a gc server if there is space. I will download the file and it can be deleted after I have a copy.

Don't worry about breaking links. If we need to restore content I will need to change the domains in the SQL anyway. And technically all external links to the ARC site should be pointing to the Kentico site anyway.

#10 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.3 to Not tracked

Hi Keith -

research.commons.gc.cuny.edu has now been moved to research-backup.commons.gc.cuny.edu. It appears that moving the site has broken some styles, probably because of some hardcoded paths somewhere. Hopefully this won't be an issue, as the move is just for backup. I recommend that you change the site's Visibility level at http://research-backup.commons.gc.cuny.edu/wp-admin/options-reading.php.

You can download a dump of all files from http://commons.gc.cuny.edu/research.zip. Let me know when you've got the files, and I'll remove the zip.

research.commons.gc.cuny.edu now redirects to the non-Commons page.

Please check all this out and make sure it's all as you'd expect.

#11 Updated by Matt Gold over 5 years ago

Redirects don't appear to be working (at least for me). Boone, can you please test?

#12 Updated by Boone Gorges over 5 years ago

http://research.commons.gc.cuny.edu is redirecting correctly on all computers I've tried.

#13 Updated by Keith Miyake over 5 years ago

I'm having the same problem as Matt. I think it's because the redirect needs a "www" in front of the "gc.cuny.edu" (see below)

curl gets this:

* About to connect() to research.commons.gc.cuny.edu port 80 (#0)
*   Trying 146.96.128.200...
* connected
* Connected to research.commons.gc.cuny.edu (146.96.128.200) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0 OpenSSL/0.9.8y zlib/1.2.5
> Host: research.commons.gc.cuny.edu
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Date: Tue, 24 Sep 2013 15:42:16 GMT
< Server: Apache/2.2.15 (Red Hat)
< Location: http://gc.cuny.edu/Degrees-Research/The-Advanced-Research-Collaborative
< Vary: Accept-Encoding
< Content-Length: 412
< Content-Type: text/html; charset=iso-8859-1
<
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="http://gc.cuny.edu/Degrees-Research/The-Advanced-Research-Collaborative">here</a>.</p>
<hr>
<address>Apache/2.2.15 (Red Hat) Server at <a href="mailto:root@gc.cuny.edu">research.commons.gc.cuny.edu</a> Port 80</address>
</body></html>
* Connection #0 to host research.commons.gc.cuny.edu left intact

but the problem is...

$ traceroute gc.cuny.edu
traceroute: Warning: gc.cuny.edu has multiple addresses; using 172.29.28.31
traceroute to gc.cuny.edu (172.29.28.31), 64 hops max, 52 byte packets
 1  146.96.24.3 (146.96.24.3)  4.937 ms  2.137 ms  4.823 ms
 2  172.29.246.53 (172.29.246.53)  4.596 ms  4.434 ms  10.509 ms
 3  172.29.246.60 (172.29.246.60)  6.987 ms  1.947 ms  3.428 ms
 4  172.29.246.25 (172.29.246.25)  3.346 ms  4.649 ms  3.292 ms
 5  * * *
 6  * * *
 7  * * *
 8  * * *

should point to...

$ traceroute www.gc.cuny.edu
traceroute to www.gc.cuny.edu (146.96.128.106), 64 hops max, 52 byte packets
 1  146.96.24.3 (146.96.24.3)  4.129 ms  2.873 ms  2.281 ms
 2  172.29.246.53 (172.29.246.53)  9.163 ms  12.860 ms  2.138 ms
 3  146.96.235.200 (146.96.235.200)  1.690 ms  1.617 ms  2.517 ms
 4  146.96.128.106 (146.96.128.106)  4.165 ms  3.906 ms  7.102 ms

#14 Updated by Keith Miyake over 5 years ago

Also, I have my copy of the directory backup so you can go ahead and pull the zip from the commons server.

Thanks!

#15 Updated by Boone Gorges over 5 years ago

Also, I have my copy of the directory backup so you can go ahead and pull the zip from the commons server.

Great. I've removed it.

I think it's because the redirect needs a "www" in front of the "gc.cuny.edu"

I've changed the redirect. Could I ask you to test? It was already working for me.

#16 Updated by Keith Miyake over 5 years ago

It's working now! Thanks, Boone.

#17 Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Resolved

Great! Marking this one resolved.

Also available in: Atom PDF