Project

General

Profile

Bug #2838

BP Docs read|edit|history|delete links not working

Added by Chris Stein almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2013-10-18
Due date:
% Done:

0%

Estimated time:

Description

Right now when you are viewing a list of Docs you need to hover over the description to see the links to read|edit|history|delete

The problem is that these links don't work on at least the iPad and possibly (probably?) on other touch devices.

This problem is related to #2837 and is because the CSS uses :hover to expose those links and that causes problems for touch.

Until we devise a more general solution to the problem, I propose a short term solution where we remove the visibility:hidden; rule on line 73 in bp-docs.css and show the links all of the time. This means we can also comment out lines 85-87 that make .row-actions visible.

Once we figure out a more general approach to hover we could revisit this.


Related issues

Related to CUNY Academic Commons - Bug #2837: Interface Issues on Touch DevicesResolved2013-10-18

History

#1 Updated by Boone Gorges almost 8 years ago

  • Target version set to 1.6

#2 Updated by Boone Gorges over 7 years ago

Fixed in BuddyPress Docs at https://github.com/boonebgorges/buddypress-docs/commit/0d3717f6070d705d39439e8a9a8136343953ddb6

We are running an old version of this plugin, so I'll do a separate fix for the Commons.

Also available in: Atom PDF