Project

General

Profile

Bug #2861

Problems with Registration

Added by Sarah Morgano over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
-
Target version:
Start date:
2013-11-01
Due date:
% Done:

0%

Estimated time:

Description

A few members have recently reported having issues with the registration process, specifically that the username field is not functioning as it should and is giving error messages when folks enter anything/remove/replace. It happened to me a couple of weeks ago and I was able to work around it by cutting and pasting the username, but it seems like there is a bug with the way that it's refreshing after someone enters something and is given an error message.

I'm adding Marilyn as a watcher because she experienced this last week trying to register someone.

History

#1 Updated by Matt Gold over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High

thanks for reporting this, Sarah.

#2 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to 1.5.8

Sarah, can you please give some more details about this? I'm not clear about what the problematic errors are, or how to reproduce them. Do you have a technique for reliably getting the error messages to show up?

#3 Updated by Sarah Morgano over 7 years ago

It was too long ago for me to remember. Marilyn, can you explain what happened to you when you tried to create that account last week?

#4 Updated by Sarah Morgano over 7 years ago

Hi Boone,

Veronica Maldonado from Macaulay reported problems registering this past Sunday. She wrote, "I keep getting an error message about the userid. I have tried the following userids:

(1) VMaldonado
(2) V_Maldonado
(3) VFMaldonado
(4) VMaldonado789

I didn't use any spaces as indicated on the registration page."

Marilyn, do you remember your experience trying to create an account for one of your colleagues at the GC?

Best,
Sarah

#5 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Resolved

Hi Sarah -

Thanks very much for the details.

It looks like the culprit is uppercase characters. WordPress Multisite does not, by default, allow them in usernames. It's not clear (to me, at least) why this restriction is in place; it's got something to do with the fact that on WordPress MU, usernames were mapped by default to blogs. In any case, it's a subject of some discussion here: http://core.trac.wordpress.org/ticket/17904

For our purposes, the restriction is not essential, so I've removed it in https://github.com/castiron/cac/commit/ee58c8fd823280136583a6784a97f2c802ece259. As of 1.5.8, users will be able to register usernames with uppercase characters.

Side note: it's crazy to me that it's only in the last month or so that this issue has come up for us. Thousands of people have registered for the Commons - is it really possible that this is the first time someone has attempted to register using uppercase characters? Or maybe this is just the first time it's been reported?

#6 Updated by Matt Gold over 7 years ago

Crazy all around! Boone, you may remember that this came up on a CBOX install, but (like you) I don't remember it coming up for the Commons before.

Also available in: Atom PDF