Project

General

Profile

Support #2899

newsletter bounce configuration

Added by Keith Miyake over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2013-11-18
Due date:
% Done:

0%

Estimated time:

Description

This is in reference to the pcp.gc.cuny.edu and globalization.gc.cuny.edu sites...

With the Tribulant Newsletters plugin, there is a section to configure email bounce handling through POP/IMAP. I can't get it to work and am hoping someone might be able to help with this issue.

I've tried setting it up using a variety of different settings, including a separate gmail account and two different @gc.cuny.edu email addresses. The plugin support mentions that gmail checking doesn't really work most of the time, so that explains that. But with the gc.cuny.edu email addresses I can't figure out why it's not working. When I try to test the server settings (mail.gc.cuny.edu port 993 or 995, my gc username, "kmiyake", which is also configured as the header return-path) it gives an "ok" response, and I see the mail-delivery subsystem message in my inbox. However the plugin doesn't detect the bounces. I can't tell if it's a problem with the plugin, a mailserver problem, or something else entirely.

Any help that can be offered with this problem would be appreciated.

History

#1 Updated by Matt Gold over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Reporter Feedback

Hi Keith. I've taken a brief look. I don't have a clear sense of what's happening yet, but I do know that the bounces have not been detected by the plugin - there's no bounces in the database.

I'm wondering if the problem is that the plugin's pseudo-cron isn't being properly fired. Could I ask you to help me test? We can check whether the cron functionality is working on your blog at all by writing a scheduled post, and then seeing if it's published at the correct time. If not, that'll narrow down the problem. (It may have something to do with the way the URL is mapped from a non-standard Commons URL.)

#3 Updated by Keith Miyake over 7 years ago

Thanks for taking a first look, Boone. I had the same intuition as you and the cron was the first thing that I tried playing with. I changed the cron for bounce handling to fire using the same cron job that the plugin uses to send emails. The cron job works, emails get sent, and no bounces are detected even though I'm seeing them in my inbox.

I don't have access to the plugin's files so I can't check the code that it's trying to execute when it runs a bounce check, but I wonder if perhaps it's a problem with the way that the plugin is trying to access the mailserver via pop/imap. When I changed the server settings in the plugin configuration, it seemed to always return "success" when I tested the server settings, even when I had bad account info entered...but without access to the server logs I can't really test if that was a lie, or perhaps that it only tested that the server was active on the specified port, but not that the account was valid.

#4 Updated by Keith Miyake over 7 years ago

Hey Boone,

So this issue is still persisting. One thing that I'm considering is switching from the Tribulant newsletter plugin to Mailpoet/Wysija, except that Mailpoet requires a premium license to use the bounce handling feature.

My question for you and the rest of the CAC team is would it be worthwhile to ask the CAC team to buy a sitewide license for Mailpoet based on the number of CAC sites using the plugin?

We bought a tribulant license a couple of years ago, and it's served very well for the 4 sites that I maintain, with the exception of bounce handling. But that license expired a while ago and so it can no longer be updated or supported. It seems that Mailpoet handles 90% of the features of the Tribulant Newsletter plugin, and I know that the premium bounce handling works correctly on my server.

#5 Updated by Matt Gold over 7 years ago

Just bought a premium mailpoet license and gave login info to Boone.

#6 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Assigned
  • Target version set to 1.5.16

Premium plugin added in https://github.com/castiron/cac/commit/77bb3edd368e1441a4f2556e5cd3702cc0b2eb83

It'll become available after the 1.5.16 release, when the premium plugin has been deployed and I've had a chance to activate our premium subscription for commons.gc.cuny.edu. I'll update this ticket when I do so, and I'll ask Keith to verify that it's solving some of his problems.

#7 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Resolved

Hi Keith - Mailpoet (Wysija Newsletters) is now available on the Commons. I believe I've registered our premium licence correctly. I'm going to mark this issue as resolved, to clear out the milestone. Please do open another ticket if you find that you're having problems with the new plugin. Thanks for your help and for your patience as we get this sorted out!

Also available in: Atom PDF