Project

General

Profile

Bug #2964

Commons specific error occurring with JADT theme

Added by Kimon Keramidas almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
-
Start date:
2014-01-16
Due date:
% Done:

0%

Estimated time:

Description

For the most part, the JADT theme is working on the Commons, except for a problem with the List Category Posts plugin I am using (http://wordpress.org/plugins/list-category-posts/). All the features of the plugin work except for the capability of assigning a template for the plugin from within a custom WP theme. I am able to use the plugin and it will display the proper results until I add the template parameter, and then it fails. There is a lot of structural change and styling within the template I designed and it is required for the theme to function properly.

I have tried to troubleshoot the problem by comparing my use of the plugin on my multi-site dev setup and I can't see anywhere in the template I designed for the JADT theme where problems would have occurred in the transition to the Commons. There are no absolute paths that would cause any problems and the shortcode in the page I am using it on is identical in both sites. I even checked to see if there could be a problem between the versions of List Category Posts that are on the Commons versus my development setup, but this templating feature is available in both.

I am wondering if there is a permissions problem on the folder where the template is stored in my theme (folder name: /JADT/list-category-posts/) or if the Commons is preventing the processing of some code for some reason. When I use my browser to inspect the page I see that none of the category listing has occurred when the template parameter is active and even the standard WP footer for my theme does not appear. This makes me think that there is some kind of stall in the process of retrieving and implementing the various php files involved in constructing the page.

I don't know if this is within the scope of Commons support, but can't really penetrate to some of the levels I need to fully troubleshoot so I thought I'd ask. You can see how the home page is supposed to look here: http://segalcenterdigital.org/WPdev/jadtdev/

Thanks
Kimon

History

#1 Updated by Matt Gold almost 8 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Reporter Feedback

Hi Kimon,

I'd be happy to take a look. But I'm not sure I totally understand how to reproduce the issue.

the capability of assigning a template for the plugin from within a custom WP theme

Can you say more about this? Can you give me steps to reproduce what you're seeing on the Commons?

#3 Updated by Kimon Keramidas almost 8 years ago

List category posts allows you to design templates specific to the plugin for more complicated formatting. The description of that functionality is near the bottom of that page (http://wordpress.org/plugins/list-category-posts/other_notes/)

If you look at the page as it is now (not working) these are the following shortcodes:

[catlist name=volume-24-number-2 numberposts=0 catlink=yes customfield_orderby="issue-order" order=asc template=JADT]
[catlist name=volume-24-number-1 numberposts=0 catlink=yes customfield_orderby="issue-order" order=asc template=JADT]

And none of the posts are listed (it should look like this: http://segalcenterdigital.org/WPdev/jadtdev/). Also the footer is not appearing.

If you delete the template parameters and it looks like this:
[catlist name=volume-24-number-2 numberposts=0 catlink=yes customfield_orderby="issue-order" order=asc]
[catlist name=volume-24-number-1 numberposts=0 catlink=yes customfield_orderby="issue-order" order=asc]

The posts are listed, but none of the page structure used to design the page in the template are there.

Since the footer is not showing and I am not getting a PHP error (and I validated the PHP of the template in my theme) I thought it might be a permissions issue.

Does that help?

Kimon

#4 Updated by Boone Gorges almost 8 years ago

Thanks for the additional details, Kimon.

This is indeed a PHP fatal error. Here's the content:

Fatal error: Call to undefined method CatListDisplayer::get_pagination() in /var/www/html/wp-content/themes/JADT/list-category-posts/JADT.php on line 117

I searched through the source code for our copy of the list-category-posts plugin, and I don't see any method by that name. Maybe the version you're using in your dev environment is not the same as the one we're using? On the Commons, we appear to be running version 0.39, with an update to 0.42.x expected in today's release: http://dev.commons.gc.cuny.edu/2014/01/05/major-commons-plugin-updates-scheduled-for-2014-1-21/ And in fact, I just downloaded 0.42.3 to take a look, and it appears that it does include a CatListDisplayer::get_pagination() method. So, it looks like you were developing with a newer version than we're running, but it should be cleared up automatically after the release later tonight.

#5 Updated by Kimon Keramidas almost 8 years ago

Great to hear Boone. Glad it was that. Next time I'll check by trying to match versions on my dev site. Thanks for looking into this, really appreciate it. I'll check after the update and let you know so we can close this ticket.

#6 Updated by Kimon Keramidas over 7 years ago

After the most recent update the List-Category-Posts plugin is no longer visible in the Plugin list. Nor is the NextPage Buttons plugin I was using. Perhaps they need to be reactivated after upgrade? Can't test functionality without the plugin available.

#7 Updated by Boone Gorges over 7 years ago

Kimon, my apologies. It looks like we messed up our update on the 21st so that the contents of the list-category-posts plugin were not included. I've issued a hotfix on the Commons. Please check again to ensure that you can now see the plugin in your Dashboard.

Reference: https://github.com/castiron/cac/commit/7588644409adc64fb91ba0912a8312b6c0616c60

As for the NextPage button: I'm able to see that plugin, and nothing I can find indicates that there'd be any issues. Please double-check to confirm.

Dom - I've added you as a watcher just as an FYI about this issue. Here's the problematic changeset: https://github.com/castiron/cac/commit/520a2ec747c4173e49522b86a8ca07b2d7e625be Not sure how this happened - maybe some temporary funkiness in the WordPress upgrader. In any case, something to keep an eye on as you're reviewing changes and committing.

#8 Updated by Kimon Keramidas over 7 years ago

All good now on the List Category Pages front. I think the NextPage Buttons got deactivated somehow (or it is possible that I neglected to activate it when setting up the site). Either wayI activated it and everything is working now. Thanks for you work.

Cheers
Kimon

#9 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Resolved

Glad it's working, Kimon! Thanks as always for your patience.

Also available in: Atom PDF