Project

General

Profile

Support #3018

Mailpoet Sender Settings

Added by Keith Miyake over 5 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2014-02-04
Due date:
% Done:

0%

Estimated time:

Description

Can I request that the network settings for the Mailpoet (Wysija) plugin be adjusted to allow individual sites to set the "from" email address? I believe it's a backend setting based on this thread: http://wordpress.org/support/topic/sender-email-not-editable-on-multisite

History

#1 Updated by Boone Gorges over 5 years ago

  • Status changed from New to Reporter Feedback

I think I've made the necessary change. Would you give it a try?

#2 Updated by Keith Miyake over 5 years ago

It doesn't seem to be working. See attached screenshot.

I tried deactivating and reactivating the plugin and that didn't help.

Also, I noticed that the email bounce configuration tab isn't appearing, even though the "premium activated" tab shows that it should be there.

#3 Updated by Keith Miyake over 5 years ago

I just checked the page's source and there is an input (type=hidden) with "from_email" as its ID. I can modify it to "type=text" using a web inspector, and when I submit the form it saves the data that I input as the input's value, however it still returns the same error and it still shows static text that says info@... (see attached screenshot).

This might be a bug in the plugin itself, but might also just be a network configuration thing.

#4 Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Assigned

Hi Keith. I spent some time trying to pick these issues apart. They both seem to be fundamental limitations on the way that Mailpoet works in a multisite configuration. Just to be sure, I've posted a support ticket with the Mailpoet team (copied below). I'll let you know what I hear back.

Matt, the support response will likely go to your email, which is the on-file address for the Mailpoet premium account. If you don't normally monitor that inbox, could I ask you to do so for the next day or two, and forward any response to me? Thanks.

===

Hello -

We've just started using Mailpoet Premium on our network. Our goal is for the owners of individual sites to be able to send newsletters, using some of Mailpoet's advanced features (particularly bounce handling). We're running what appear to be permissions issues, and were hoping you could clarify whether what we're seeing is the intended behavior.

1. We'd like for individual site owners to be able to configure their own From address. From the documentation, it looks like this ought to be possible if the "Configure each site manually" radio button is checked (ms_sending_config = "one-each"). But the auto-generated email address continues to appear for all users: . Is this expected? Is there a way to override this? Is it possible to override it on a per-site basis?

2. It appears that the Bounce Handling tab is hardcoded to be available only to network administrators (WYSIJA::current_user_can( 'manage_network' )). Is there a technical reason why this is the case? I assume it's because Bounce Handling settings are saved and applied network-wide. If so, is there a technical reason why this would be the case? Again, ideally, we'd like our individual site owners to be able to manage their own configs.

Thanks!

#5 Updated by Matt Gold over 5 years ago

Watching and will forward anything I hear.

#6 Updated by Boone Gorges over 5 years ago

  • Category name set to WordPress Plugins
  • Target version set to Not tracked

Hi Keith - I've gotten some feedback.

- Here's how to change the From address. Wysija > Settings > Send with.... Select "Your own website" (or another option if you wish). That'll free up the From field on the Basics tab.

- It turns out that Bounce Handling is indeed networkwide. I'm not certain that I totally understand what bounce handling is or how it's supposed to work, but I'm happy to set up a Commons-wide bounce handler account, which should hopefully work smoothly for you. Does that sound OK?

#7 Updated by Keith Miyake over 5 years ago

Ahh, it's so simple and yet not at all apparent. That seems like it worked.

For bounce handling, I'd love it if you could set up a network-wide account. Maybe something like ? I think it just needs to be a gc.cuny.edu address (since that's what we're sending with) and have pop/imap access on the same account.

Thanks, Boone.

#8 Updated by Boone Gorges over 5 years ago

  • Assignee set to Matt Gold

Glad we're on the right track, Keith :)

Matt, if Keith is correct that we'll need a gc.cuny.edu address, I may have to ask you to make the address request. Perhaps ?

#9 Updated by Matt Gold over 5 years ago

Requested. I'll let you know what I hear.

#10 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Resolved

I don't think we ever got this bounce-handler, and given the policies at the GC about email accounts, I'm not sure that we will. For the time being, I'm going to reject this ticket, because I assume that bounce handling is a nice-to-have but not critical feature here.

Also available in: Atom PDF