Project

General

Profile

Bug #3022

Blog visibility set to public but not visible publicly

Added by Maura Smale over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Blogs
Target version:
Start date:
2014-02-06
Due date:
% Done:

0%

Estimated time:
0.50 h

Description

Hi everyone, just noticed another weird thing with the course blog for ITP Core 2. While we've set the Reading settings to "Allow search engines to index this site," when a non-logged-in user tries to view the blog they get the message that the blog is only visible to Commons members. Here's the blog: http://2014core2.commons.gc.cuny.edu/. If it's useful to know, we did have the blog visible only to admins for a while as we were prepping the course, but once the semester started we switched over to public. Thanks!

History

#1 Updated by Matt Gold over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Hi Maura,

I just tried to access the blog as a non-logged in user and didn't have any problems. I've added the community team to this ticket so that they can test, as well.

Scott, Sarah, Marilyn: can you please try to access the site as non-logged-in users and let us know what you find?

Maura, if we find that it's working now, it might be useful to find out more about the experience & set-up of the person who reported the issue (unless it was you who experienced this)

#2 Updated by Boone Gorges over 7 years ago

  • Target version set to Not tracked

Same here. I'm able to access the blog without a problem. Maura, maybe your browser cache was being unusually sticky?

#3 Updated by Maura Smale over 7 years ago

Thanks Matt and Boone, I can access it too from that link, but it's not entirely a false alarm, rather perhaps a different bug -- what I can't do is view the blog when I click the Blog link on the Group page when I'm not logged in. So from here http://commons.gc.cuny.edu/groups/itp-core-2-spring-2014/ if I click Blog on the left I get the "You must login..." screen.

Though thinking on it now, maybe this isn't a bug, and maybe I'm the only person who would think to do this! The reason I even try to get to the blog this way is it seems like the fastest way to get there from the homepage if the group is in the recently active groups list but the most recent blog post isn't in the recently active blog list anymore.

Either way this is super, duper, totally unurgent. Thanks!

#4 Updated by Boone Gorges over 7 years ago

  • Category name changed from WordPress (misc) to Group Blogs
  • Target version changed from Not tracked to 1.6
  • Estimated time set to 0.50 h

Aha, confirmed! I'd call this an "unimplemented feature" rather than a "bug", but let's not quibble :) It should be fairly straightforward to fix.

#5 Updated by Marilyn Weber over 7 years ago

Confirmed for me too!

#6 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Resolved

I've put a workaround into place in https://github.com/castiron/cac/commit/41001bc4e180d5005c0b9816640e669d009658d7. Marking resolved. Thanks for the patience, Maura!

#7 Updated by Maura Smale over 7 years ago

Thanks Boone! I think I'm the only one who noticed, no worries. :)

Also available in: Atom PDF