Project

General

Profile

Bug #3071

Twenty Fourteen theme differences

Added by Marilyn Weber almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Themes
Target version:
Start date:
2014-02-24
Due date:
% Done:

0%

Estimated time:
1.00 h

Description

Not sure if this is a Redmine issue. I've attached three screenshots to show how the Twenty Fourteen theme
1) loses both the background and sidebar in IE (and truncates "CUNY Academic Commons" to "CUNY Ac"
2) does not allow text or images to fill the middle part of the screen, instead displaying quite a bit of white "dead" space. (I suspect this might be something I can figure out.)

Any tips? Thanks, all!

Firefox2014.JPG (122 KB) Firefox2014.JPG Marilyn Weber, 2014-02-24 04:38 PM
IE2014.JPG (115 KB) IE2014.JPG Marilyn Weber, 2014-02-24 04:38 PM
Chrome2014.JPG (140 KB) Chrome2014.JPG Marilyn Weber, 2014-02-24 04:38 PM
CUNYAc.JPG (22.7 KB) CUNYAc.JPG Marilyn Weber, 2014-03-21 10:19 AM

History

#1 Updated by Marilyn Weber almost 8 years ago

Screenshots hopefully attached

#2 Updated by Matt Gold almost 8 years ago

  • Category name set to WordPress Themes
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#3 Updated by Boone Gorges almost 8 years ago

  • Target version set to 1.5.19
  • Estimated time set to 1.00 h

I will take a look at the IE issue.

does not allow text or images to fill the middle part of the screen, instead displaying quite a bit of white "dead" space.

I think this is just the design of the theme. You can attempt to modify it with custom CSS if you'd like, but I think this is less a bug than a conscious design choice.

#4 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Resolved

Marilyn - It looks like both issues were caused by some dumb behavior in IE related to what they call "compatibility view". I'm putting in a fix for 1.5.19 that will force this mode off for the Twenty Fourteen theme. I'll be doing the release shortly - feel free to check later today. Thanks for the report.

#5 Updated by local admin over 7 years ago

Hi, Boone,

I'm having the same problem on both Firefox and Chrome (newest versions of all). I'm seeing the same things that are in Marilyn's screenshots.

Best,

Andy

#6 Updated by local admin over 7 years ago

Also, this is the ticket I raised for what I was seeing: http://redmine.gc.cuny.edu/issues/3114

#7 Updated by Matt Gold over 7 years ago

  • Status changed from Resolved to Assigned
  • Target version changed from 1.5.19 to 1.5.22

reopening due to unresolved issues

#8 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Reporter Feedback

Andy, can you please share the following:

- link to the problematic page
- description of setup (OS + browser versions)

#9 Updated by Marilyn Weber over 7 years ago

By the way, the dumb behavior in IE which cuts off the upper right hand corner "CUNY Academic Commons" pull-down menu in Twenty Fourteen, does the same in Imbalance 2. Screenshot attached

#10 Updated by local admin over 7 years ago

Hi Boone,

For some reason I didn't get an update via email on this, sorry for the delay.

Here's the link: http://newestblogever.commons.gc.cuny.edu/

I'm seeing this on Macs, both at home on my 10.9.2 machine and at the New Media Lab on a 10.7.8 machine. It's happening on all browsers. Safari 7.0.2, Firefox 28.0, and Chrome 33.

#11 Updated by Boone Gorges over 7 years ago

Thanks, Andy. I'm having a look right now, and it's not clear to me what the issues are. I do see that the admin bar is a little bit shorter than it ought to be, but I don't see the original issues that Marilyn reported. Could you please specify the precise problems you're seeing, with screenshots if you think that'd be helpful? Thanks.

#12 Updated by local admin over 7 years ago

Hi Boone,

Here's the ticket I started a couple of weeks ago that has screenshots and specifics:

http://redmine.gc.cuny.edu/issues/3114

Best,

ANdy

#13 Updated by Boone Gorges over 7 years ago

Thanks, Andy. Those screenshots make the issues clearer.

There are some inconsistencies between a few hardcoded values in twentyfourteen's stylesheets and the way that we override WP's adminbar styles. Should be resolved by https://github.com/castiron/cac/commit/7a279cb891af411f76aa827f0c087fd6847c2afe and https://github.com/castiron/cac/commit/f45f1dddb86468cfe1ae9cd658a1d6ede15826b7

I'm going to mark this ticket as Resolved. Andy and Marilyn, if you continue to have problems after the 1.5.22 release (later this evening), please feel free to reopen with details.

#14 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Resolved

Also available in: Atom PDF