Project

General

Profile

Bug #315

Can't upload images to gallery

Added by Matt Gold about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2010-08-29
Due date:
% Done:

0%

Estimated time:

Description

Upon trying to upload images through the media uploader to the Image Credits page ( http://commons.gc.cuny.edu/about/images/ ), I received the following error message: "Sorry, you must delete files before you can upload any more." That seems strange, since I think we only have 8 or so images in the Library. Maybe we've exceeded the size limit somewhere?

History

#1 Updated by Boone Gorges about 11 years ago

  • Status changed from Assigned to Reporter Feedback

I think the problem is that BuddyPress-wide uploaded files (documents, etc) are being stored in blogs.dir/1/files and thus being counted against blog 1's storage limit. There are a few solutions:
1) Turn off the blog upload space check (Site Admin > Options). This can be done right away.
2) Write a snippet that skips the blog storage space check for blog 1. This isn't too hard but it will have to wait for 1.0.2.

FWIW I think the way that file uploads are handled, especially on blog 1, is changed pretty radically in WP 3.0. So it might not be worth putting a ton of time into the issue. But I do see a way to fix it with just a line or two of code.

Side note: This doesn't affect the ability of BuddyPress plugins to upload to this space, because those uploads don't get run through wpmu_checkAvailableSpace, while Dashboard > Media > Add Media does. Essentially, the fix involves unhooking that function on blog_id = 1.

#2 Updated by Matt Gold about 11 years ago

Whatever you think is best.

#3 Updated by Boone Gorges about 11 years ago

  • Status changed from Reporter Feedback to Hold
  • Target version changed from Not tracked to 1.1

I'm going to set the ticket to Hold with a target version of 1.1, in the hopes that upgrading to WP 3.0 will make the problem go away magically. In the meantime, if you want to upload images for use on the main Commons blog, upload them to a different blog (like the News blog) and hotlink.

#4 Updated by Matt Gold about 11 years ago

Okay -- that sounds good, and it's a decent temporary solution.

#5 Updated by Boone Gorges about 11 years ago

  • Status changed from Hold to Resolved
  • Target version changed from 1.1 to 1.0.3

Fixed in https://github.com/castiron/cac/commit/41dd62b8bae3a8aafa048736f529aa0933f97e11

https://github.com/castiron/cac/commit/4141dacc0a308ce383a5c573f6860fcc0912474c should ensure that the fix sticks after we've upgraded to 3.0. If it doesn't work, please reopen the ticket.

Also available in: Atom PDF