Project

General

Profile

Bug #320

Multiple listings of account in BP group

Added by Matt Gold over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2010-08-31
Due date:
% Done:

0%

Estimated time:

Description

One of our members (see email for identity) reports that he joined a group, but now seems himself listed twice there. This may be related to an earlier ticket in which this person reported getting multiple notifications of group activities.


Related issues

Related to CUNY Academic Commons - Bug #323: Multiple listings of member account in BP groupResolved2010-09-01

History

#1 Updated by Boone Gorges over 8 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Not tracked

The only cases where I've seen this happen is where people have invited themselves to groups, or unjoined and joined, or some other funny business. Generally, it's nearly impossible for me troubleshoot this kind of problem without being able to reproduce it.

For this case, I have removed the duplicate group membership.

#2 Updated by Matt Gold over 8 years ago

Can you take a quick look through his other groups to see whether he's listed twice in any of them?

#3 Updated by Boone Gorges over 8 years ago

There was one other one, which I also corrected.

If this happens again, please open another ticket, and I will investigate further. It's possible for me to write something that will crawl through and correct all instances of double-membership, though I'd rather not if it's not a common issue.

#4 Updated by Matt Gold over 8 years ago

Sounds good.

#5 Updated by Matt Gold over 8 years ago

Same user reports that some groups appear twice in "My Groups" listing on BP Admin bar, though he is only listed once in the groups themselves. See email for details. Known issue?

#6 Updated by Boone Gorges over 8 years ago

Those menus are cached by WordPress. Since I deleted the item manually, it's possible that WP didn't know to reset the cache. The member should either wait a few days for the server cache to clear, or try joining and immediately unjoining a group, which should kickstart the cache deletion.

#7 Updated by Matt Gold over 8 years ago

Thanks, Boone -- I'll pass that on.

Also available in: Atom PDF