Project

General

Profile

Feature #322

Raising Limitation on Emailed Invites

Added by Matt Gold about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2010-09-01
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,

I just got off the phone with the leader of one of the groups that we're bringing onto the Commons. He wants to use the invite by email feature, but his group has about forty people. Brian told me that in his experience, there is a limit of 20 people that can be invited at a time, and that, say, when 10 people accept the invitation, another 10 slots open up.

How hard would it be to open that up just a bit -- to, say, an upward limit of 50 people -- even if only for a limited time so that we could get this group onto the site? And if it's possible, how soon could you get that set up? If it's going to work, we'll need it by tomorrow.

If this sounds like an unreasonable timeline or request, please let me know and we'll figure something else out. If you could let me know what you think asap so that we can make other arrangements if need be, I'd appreciate it. Thanks.

History

#1 Updated by Boone Gorges about 11 years ago

I'm confused by what this ticket refers to. When Brian was talking about an upper limit on invitations, he was talking about invitations to join a group (it was in the context of inviting group admins to the Group for Group Admins). You are talking about invitations to join the site. The former are handled by BuddyPress, which may indeed limit pending invitations to join a group. The latter are handled by Invite Anyone, and I can tell you from Intimate Knowledge of that plugin that there is no ceiling for pending invitations to join the site.

The overlap would be if the invitation to join the site (through Invite Anyone) included a group invitation, as Invite Anyone allows. I assume that this will be the case, so I'll start investigating the situation with BuddyPress.

#2 Updated by Matt Gold about 11 years ago

Thanks very much for your quick response -- this is great to know. And, yes, we were hoping to invite them both to the site and to the group through the bodacious Invite Anyone plugin.

#3 Updated by Boone Gorges about 11 years ago

Brian, can you clarify what happens at the 20 member cutoff?

#4 Updated by Brian Foote about 11 years ago

Boone Gorges wrote:

Brian, can you clarify what happens at the 20 member cutoff?

Back when I setting up the Group for Group admins I noticed that if I invited say 20 people and 12 took the invitation and joined the group, the 8 who were pending held slots so that I could only invite another round of 12 people. 20 isn't the exact number, I don't recall exactly how many it was, but there was a small-ish cap. It made it so that I had to basically invite people in stages as the lingering people from the list finally joined up.

I was, of course, inviting people who were already members of the site and not new to the Commons.

#5 Updated by Boone Gorges about 11 years ago

I'm unable to reproduce this on my local version of the Commons.

When I go to /groups/my-group/invite-anyone, I can add as many people to the list as I want. When I click Send Invites and the page refreshes, they all remain (though sometimes are reordered somewhat).

There are two things that might cause the behavior you've seen, Brian:
1) BuddyPress has an internal cap on pending group invitations
2) There is a limit to how many pending invitations can be displayed on the group invitation page

Re (1): I combed through the code, and even talked to one of BuddyPress's lead developers about it. Neither of us could find anything that would place such a limitation. Re (2): As I say above, my local version doesn't show a limit on how many pending invites can be displayed.

This is a very hard thing to test on the production site (you don't want to go around inviting 50 folks to a group haphazardly...) so let me ask for more clarification. When you initially went to the screen to invite people, were you limited in how many people you could add on that first visit? In what way were you limited? Did you get an error warning? Was a box grayed out? Did you try adding people and they simply weren't added? Or did they all appear on the right, but when you clicked "Send Invites" and the page refreshed, only 20ish remained?

#6 Updated by Brian Foote about 11 years ago

It could very well have been that the list of icons simply quit, but that I was capable of adding more people though I did not realize it. Let me go back to the group now because there's still a list of pending members who never bothered to join.

#7 Updated by Brian Foote about 11 years ago

Looking back at the GFGA project - because the list you check boxes in isn't alphabetical I had to search each name from my spreadsheet and then add them in. I remember that once the list of icons stopped I assumed I had reached a max. It seems very likely that I perceived an inability to add members because of that.

#8 Updated by Boone Gorges about 11 years ago

Well that certainly would be a happy solution to the problem!

Thanks for researching this, Brian. Matt, given my and Brian's research, I think we can go ahead and tell the member to make his invitations, with the assurance that we'll be on call to help if need be.

#9 Updated by Boone Gorges about 11 years ago

  • Status changed from Assigned to Reporter Feedback

#10 Updated by Matt Gold about 11 years ago

Sounds like this is very likely to be resolved, but let's wait to mark it so until tomorrow, when I'll invite 40-odd people to the Commons.

Boone, I very much appreciate your quick attention to this. And Brian, thanks for all of the work you've been doing to help bring CSI on board.

#11 Updated by Matt Gold about 11 years ago

I was able to invite everyone, so I'm going to mark this as resolved.

A related question: the Invite Anyone intro text includes the following note: "You can only invite people whose email addresses end in one of the following domains: *.cuny.edu"

However, it appears that I was able to invite people who weren't using cuny.edu accounts. So, did the invites go through, in which case that text should be revised to say that members need to sign up with cuny.edu address, or did they not get sent, in which case plugin is erroneously showing them as having been sent?

#12 Updated by Matt Gold about 11 years ago

  • Status changed from Reporter Feedback to Resolved

#13 Updated by Boone Gorges about 11 years ago

I'll open as a separate ticket.

Also available in: Atom PDF