Project

General

Profile

Bug #3235

Random Image Plugin

Added by Sarah Morgano over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2014-05-28
Due date:
% Done:

0%

Estimated time:

Description

The Random image plugin has a bug that won't allow for multiple random image shortcodes on a page. Kimon corrected this by removing the random image shortcode from the Publications page of http://thesegalcenter.org/publications/ and replacing it with static images.

History

#1 Updated by Matt Gold over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version changed from 1.6.5 to 1.6.6

Kimon - Would you mind sharing some more precise steps to reproduce the issue? Thanks.

#3 Updated by Kimon Keramidas over 7 years ago

Essentially when you use this plugin you place this short code into your text to get a random image: [random-image]

You can add attachment or post ids to pull specific subsets of images. We had been doing that to pull random images of our collections of book covers, journal covers, and digital intitiatives on the same page. The plugin had been working fine until the most recent WP update at which point anywhere there was a multiple instance of the embed code it caused an error and crashed any of the HTML after the second instance of the embed code. I had to remove the multiple instances so that any page I was using the embed code on had only one instance, with the other instances being replaced by a single static image.

Here is a link to a report of the bug on Wordpress:

https://wordpress.org/support/topic/multiple-shortcodes-on-a-page-1

#4 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Kimon. It looks like this was a result of the plugin author not really knowing what he's doing. I'm going to make a fix directly in the plugin files, and then assume that the plugin developer will implement a fix for his next release (or never do another release - it was over two years between the two previous releases).

Fixed in https://github.com/castiron/cac/commit/cbdb5c623e2dae7a89f317d6e16033c53178da7c. This will be available in the next release.

Also available in: Atom PDF