Project

General

Profile

Bug #3593

registration problems

Added by Marilyn Weber about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Registration
Target version:
Start date:
2014-10-22
Due date:
% Done:

0%

Estimated time:

Description

Beth Vayshenker is trying to use her address to register on the Commons, and is having two problems I can replicate:

1) The email is triggering the "Sorry, that email address is not allowed" error.
2) bethvayshenker is triggering the "Only lowercase letters (a-z) and numbers are allowed" error.

History

#1 Updated by Matt Gold about 7 years ago

  • Category name set to Registration
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges about 7 years ago

  • Priority name changed from Normal to High
  • Target version set to 1.7.3

Thanks for the report, Marilyn. This is related to the WP 4.0 upgrade.

Technical explanation: WP 4.0 made the 'errors' property of `WP_Error` objects private. To make our wildcard email whitelist work, I'd been catching failed registration attempts from BuddyPress and unsetting the relevant errors. This no longer works. My workaround is to rebuild the error object, using the data from the existing one but skipping the one about invalid email addresses.

Resolved in https://github.com/cuny-academic-commons/cac/commit/774953f0f77c05502faafdf8c272bba33e539f5d and ready to test on the production site.

I was unable to reproduce the problem with the username. I'm wondering if this is a case of user error. Could I ask you to get the user to try it again?

#3 Updated by Boone Gorges about 7 years ago

  • Status changed from Assigned to Reporter Feedback

#4 Updated by Marilyn Weber about 7 years ago

This is resolved! She's now signed up. Thanks, Boone.

#5 Updated by Boone Gorges about 7 years ago

  • Target version changed from 1.7.3 to 1.7.2

Thanks for following up, Marilyn.

#6 Updated by Boone Gorges about 7 years ago

  • Status changed from Reporter Feedback to Resolved

Also available in: Atom PDF